hdu2196(求树的直径或树形dp)

123 篇文章 0 订阅
46 篇文章 0 订阅

Computer

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 6231    Accepted Submission(s): 3145


Problem Description
A school bought the first computer some time ago(so this computer's id is 1). During the recent years the school bought N-1 new computers. Each new computer was connected to one of settled earlier. Managers of school are anxious about slow functioning of the net and want to know the maximum distance Si for which i-th computer needs to send signal (i.e. length of cable to the most distant computer). You need to provide this information.


Hint: the example input is corresponding to this graph. And from the graph, you can see that the computer 4 is farthest one from 1, so S1 = 3. Computer 4 and 5 are the farthest ones from 2, so S2 = 2. Computer 5 is the farthest one from 3, so S3 = 3. we also get S4 = 4, S5 = 4.
 

Input
Input file contains multiple test cases.In each case there is natural number N (N<=10000) in the first line, followed by (N-1) lines with descriptions of computers. i-th line contains two natural numbers - number of computer, to which i-th computer is connected and length of cable used for connection. Total length of cable does not exceed 10^9. Numbers in lines of input are separated by a space.
 

Output
For each case output N lines. i-th line must contain number Si for i-th computer (1<=i<=N).
 

Sample Input
  
  
5 1 1 2 1 3 1 1 1
 

Sample Output
  
  
3 2 3 4 4

题意:分别求出所有点到叶子结点的最远距离,树的边有权值。

思路:很多题解都是树形dp,我想想认为求一个树直径之后直接首尾各自一遍dfs原图就能记录到了,所以试了试,结果发现还行,的确过了。。。另外一种思路树形dp网上题解太多就不一一解释了……

//#pragma comment(linker, "/STACK:102400000,102400000")
#include <iostream>
#include<string.h>
#include<vector>
#include<queue>
#include<algorithm>
#include<stdio.h>
#include<math.h>
#include<map>
#include<stdlib.h>
#include<time.h>
#include<stack>
#include<set>
#include<deque>
using namespace std;
typedef long long ll;
const int N=10010;
int head[N];
int ip;
struct edgenode
{
    int to;
    int next;
    int w;
} tu[N*2];
void init()
{
    ip=0;
    memset(head,-1,sizeof(head));
}
void add(int u,int v,int w)
{
    tu[ip].w=w,tu[ip].to=v,tu[ip].next=head[u],head[u]=ip++;
}
int st,ed,len;
void dfs(int now,int pre,int sum)
{
    if(sum>len)len=sum,st=now;
    for(int k=head[now]; k!=-1; k=tu[k].next)
    {
        int to=tu[k].to;
        if(to!=pre)
            dfs(to,now,sum+tu[k].w);
    }
}
int dis1[N],dis2[N];
void dfs2(int now,int pre)
{
    for(int k=head[now]; k!=-1; k=tu[k].next)
    {
        int to=tu[k].to;
        if(to!=pre)
            dis1[to]=dis1[now]+tu[k].w,dfs2(to,now);
    }
}
void dfs3(int now,int pre)
{
    for(int k=head[now]; k!=-1; k=tu[k].next)
    {
        int to=tu[k].to;
        if(to!=pre)
            dis2[to]=dis2[now]+tu[k].w,dfs3(to,now);
    }
}
int main()
{
    int n;
    while(~scanf("%d",&n))
    {
        init();
        memset(dis1,0,sizeof(dis1));
        memset(dis2,0,sizeof(dis2));
        for(int i=2; i<=n; i++)
        {
            int a,b;
            scanf("%d%d",&a,&b);
            add(i,a,b);
            add(a,i,b);
        }
        len=0;
        st=1;
        dfs(1,-1,0);
        ed=st;
        len=0;
        dfs(st,-1,0);
        dfs2(st,0);
        dfs3(ed,0);
        for(int i=1; i<=n; i++)
            printf("%d\n",max(dis1[i],dis2[i]));
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值