usaco1.3.2 Barn Repair

一. 原题

Barn Repair

It was a dark and stormy night that ripped the roof and gates off the stalls that hold Farmer John's cows. Happily, many of the cows were on vacation, so the barn was not completely full.

The cows spend the night in stalls that are arranged adjacent to each other in a long line. Some stalls have cows in them; some do not. All stalls are the same width.

Farmer John must quickly erect new boards in front of the stalls, since the doors were lost. His new lumber supplier will supply him boards of any length he wishes, but the supplier can only deliver a small number of total boards. Farmer John wishes to minimize the total length of the boards he must purchase.

Given M (1 <= M <= 50), the maximum number of boards that can be purchased; S (1 <= S <= 200), the total number of stalls; C (1 <= C <= S) the number of cows in the stalls, and the C occupied stall numbers (1 <= stall_number <= S), calculate the minimum number of stalls that must be blocked in order to block all the stalls that have cows in them.

Print your answer as the total number of stalls blocked.

PROGRAM NAME: barn1

INPUT FORMAT

Line 1:M, S, and C (space separated)
Lines 2-C+1:Each line contains one integer, the number of an occupied stall.

SAMPLE INPUT (file barn1.in)

4 50 18
3
4
6
8
14
15
16
17
21
25
26
27
30
31
40
41
42
43

OUTPUT FORMAT

A single line with one integer that represents the total number of stalls blocked.

SAMPLE OUTPUT (file barn1.out)

25
[One minimum arrangement is one board covering stalls 3-8, one covering 14-21, one covering 25-31, and one covering 40-43.] 


二. 分析
题意:在[1, s]闭区间上散落有c个点,要求用最多m个区间去覆盖所有的点。求这些区间的长度之和最小值。方法就是去找这些点之间的最大空格,选区间的时候跳过这些空格就行啦。有个小坑,供你使用的区间个数可能比点的个数还多(m>c),最后需要减去的空格个数应当是min(c, m)


三. 代码

运行结果:

USER: Qi Shen [maxkibb3]
TASK: barn1
LANG: C++

Compiling...
Compile: OK

Executing...
   Test 1: TEST OK [0.000 secs, 4184 KB]
   Test 2: TEST OK [0.000 secs, 4184 KB]
   Test 3: TEST OK [0.000 secs, 4184 KB]
   Test 4: TEST OK [0.000 secs, 4184 KB]
   Test 5: TEST OK [0.000 secs, 4184 KB]
   Test 6: TEST OK [0.000 secs, 4184 KB]
   Test 7: TEST OK [0.000 secs, 4184 KB]
   Test 8: TEST OK [0.000 secs, 4184 KB]
   Test 9: TEST OK [0.000 secs, 4184 KB]
   Test 10: TEST OK [0.000 secs, 4184 KB]

All tests OK.
 
 
AC代码:
 
 
/*
ID:maxkibb3
PROG:barn1
LANG:C++
*/

#include<cstdio>
#include<algorithm>
using namespace std;

const int MAX = 205;
int m, s, c;
int a[MAX];
int b[MAX];
int ans;

struct cmp {
	bool operator () (const int &obj1, const int &obj2) const {
		return obj1 > obj2;
	}	
};

int main() {
	freopen("barn1.in", "r", stdin);
	freopen("barn1.out", "w", stdout);
	scanf("%d%d%d", &m, &s, &c);
	for(int i = 0; i < c; i++) {
		scanf("%d", &a[i]);
	}
	sort(a, a + c);
	for(int i = 1; i < c; i++) {
		b[i] = a[i] - a[i - 1];
	}
	sort(b + 1, b + c, cmp());
	
	ans = a[c - 1] - a[0] + 1;
	for(int i = 1; i < min(c, m); i++) {
		ans -= b[i] - 1;
	}
	printf("%d\n", ans);
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值