usaco3.1.5 Stamps

一 原题

Stamps

Given a set of N stamp values (e.g., {1 cent, 3 cents}) and an upper limit K to the number of stamps that can fit on an envelope, calculate the largest unbroken list of postages from 1 cent to M cents that can be created.

For example, consider stamps whose values are limited to 1 cent and 3 cents; you can use at most 5 stamps. It's easy to see how to assemble postage of 1 through 5 cents (just use that many 1 cent stamps), and successive values aren't much harder:

  • 6 = 3 + 3
  • 7 = 3 + 3 + 1
  • 8 = 3 + 3 + 1 + 1
  • 9 = 3 + 3 + 3
  • 10 = 3 + 3 + 3 + 1
  • 11 = 3 + 3 + 3 + 1 + 1
  • 12 = 3 + 3 + 3 + 3
  • 13 = 3 + 3 + 3 + 3 + 1.

However, there is no way to make 14 cents of postage with 5 or fewer stamps of value 1 and 3 cents. Thus, for this set of two stamp values and a limit of K=5, the answer is M=13.

The most difficult test case for this problem has a time limit of 3 seconds.

PROGRAM NAME: stamps

INPUT FORMAT

Line 1:Two integers K and N. K (1 <= K <= 200) is the total number of stamps that can be used. N (1 <= N <= 50) is the number of stamp values.
Lines 2..end:N integers, 15 per line, listing all of the N stamp values, each of which will be at most 10000.

SAMPLE INPUT (file stamps.in)

5 2
1 3

OUTPUT FORMAT

Line 1:One integer, the number of contiguous postage values starting at 1 cent that can be formed using no more than K stamps from the set.

SAMPLE OUTPUT (file stamps.out)

13



二 分析

dp[i]代表获得价值i所需要的最少邮票数,dp[i]多于k时,输出i-1即可。


三 代码

运行结果:
USER: Qi Shen [maxkibb3]
TASK: stamps
LANG: C++

Compiling...
Compile: OK

Executing...
   Test 1: TEST OK [0.000 secs, 11992 KB]
   Test 2: TEST OK [0.000 secs, 11992 KB]
   Test 3: TEST OK [0.000 secs, 11992 KB]
   Test 4: TEST OK [0.000 secs, 11992 KB]
   Test 5: TEST OK [0.000 secs, 11992 KB]
   Test 6: TEST OK [0.000 secs, 11992 KB]
   Test 7: TEST OK [0.000 secs, 11992 KB]
   Test 8: TEST OK [0.000 secs, 11992 KB]
   Test 9: TEST OK [0.000 secs, 11992 KB]
   Test 10: TEST OK [0.032 secs, 11992 KB]
   Test 11: TEST OK [0.302 secs, 11992 KB]
   Test 12: TEST OK [0.130 secs, 11992 KB]
   Test 13: TEST OK [0.000 secs, 11992 KB]

All tests OK.

Your program ('stamps') produced all correct answers! This is your submission #4 for this problem. Congratulations!


AC代码:
/*
ID:maxkibb3
LANG:C++
PROG:stamps
*/

#include<cstdio>
#include<algorithm>
using namespace std;

const int MAX_ELE = 10000;
const int MAX_K = 200;
const int MAX_N = 50;

int k, n;
int p[MAX_N];
int dp[MAX_ELE * MAX_K + 1];

int main() {
    freopen("stamps.in", "r", stdin);
    freopen("stamps.out", "w", stdout);
    scanf("%d%d", &k, &n);
    int max_ele = 0;
    for(int i = 0; i < n; i++) {
        scanf("%d", &p[i]);
        if(max_ele < p[i])
            max_ele = p[i];
    }
    sort(p, p + n);
    
    for(int i = 1; i <= max_ele * k + 1; i++) {
        dp[i] = k + 1;
    }

    for(int i = 1;; i++) {
        for(int j = 0; j < n; j++) {
            if(i - p[j] < 0) break;
            dp[i] = min(dp[i - p[j]] + 1, dp[i]);
        }
        if(dp[i] > k) {
            printf("%d\n", i - 1);
            break;
        }
    }
    return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值