一 原题
Hal Burch
Every time it rains on Farmer John's fields, a pond forms over Bessie's favorite clover patch. This means that the clover is covered by water for awhile and takes quite a long time to regrow. Thus, Farmer John has built a set of drainage ditches so that Bessie's clover patch is never covered in water. Instead, the water is drained to a nearby stream. Being an ace engineer, Farmer John has also installed regulators at the beginning of each ditch, so he can control at what rate water flows into that ditch.
Farmer John knows not only how many gallons of water each ditch can transport per minute but also the exact layout of the ditches, which feed out of the pond and into each other and stream in a potentially complex network. Note however, that there can be more than one ditch between two intersections.
Given all this information, determine the maximum rate at which water can be transported out of the pond and into the stream. For any given ditch, water flows in only one direction, but there might be a way that water can flow in a circle.
PROGRAM NAME: ditch
INPUT FORMAT
Line 1: | Two space-separated integers, N (0 <= N <= 200) and M (2 <= M <= 200). N is the number of ditches that Farmer John has dug. M is the number of intersections points for those ditches. Intersection 1 is the pond. Intersection point M is the stream. |
Line 2..N+1: | Each of N lines contains three integers, Si, Ei, and Ci. Si and Ei (1 <= Si, Ei <= M) designate the intersections between which this ditch flows. Water will flow through this ditch from Si to Ei. Ci (0 <= Ci <= 10,000,000) is the maximum rate at which water will flow through the ditch. |
SAMPLE INPUT (file ditch.in)
5 4 1 2 40 1 4 20 2 4 20 2 3 30 3 4 10
OUTPUT FORMAT
One line with a single integer, the maximum rate at which water may emptied from the pond.
SAMPLE OUTPUT (file ditch.out)
50
二 分析
三 代码
USER: Qi Shen [maxkibb3] TASK: ditch LANG: C++ Compiling... Compile: OK Executing... Test 1: TEST OK [0.000 secs, 4348 KB] Test 2: TEST OK [0.000 secs, 4348 KB] Test 3: TEST OK [0.000 secs, 4348 KB] Test 4: TEST OK [0.000 secs, 4348 KB] Test 5: TEST OK [0.000 secs, 4348 KB] Test 6: TEST OK [0.000 secs, 4348 KB] Test 7: TEST OK [0.000 secs, 4348 KB] Test 8: TEST OK [0.000 secs, 4348 KB] Test 9: TEST OK [0.000 secs, 4348 KB] Test 10: TEST OK [0.011 secs, 4348 KB] Test 11: TEST OK [0.000 secs, 4348 KB] Test 12: TEST OK [0.000 secs, 4348 KB] All tests OK.
Your program ('ditch') produced all correct answers! This is your submission #3 for this problem. Congratulations!
/*
ID:maxkibb3
LANG:C++
PROB:ditch
*/
#include<cstdio>
const int MAXV = 205;
const int MAXC = 1e7 + 5;
int m, n;
int c[MAXV][MAXV];
bool vis[MAXV];
int ans;
int min(int a, int b) {
return (a < b) ? a : b;
}
void init() {
scanf("%d%d", &m, &n);
for(int i = 0; i < m; i++) {
int s, e, _c;
scanf("%d%d", &s, &e);
scanf("%d", &_c);
c[s][e] += _c;
}
}
int dfs(int idx, int flow) {
if(idx == n) return flow;
for(int i = 1; i <= n; i++) {
if(vis[i]) continue;
int f = min(flow, c[idx][i]);
if(f == 0) continue;
vis[i] = true;
int d = dfs(i, f);
//vis[i] = false;
if(d != 0) {
c[idx][i] -= d;
c[i][idx] += d;
return d;
}
}
return 0;
}
void solve() {
while(true) {
for(int i = 1; i <= n; i++) vis[i] = false;
vis[1] = true;
int delta = dfs(1, MAXC);
if(delta == 0) break;
ans += delta;
}
printf("%d\n", ans);
}
int main() {
freopen("ditch.in", "r", stdin);
freopen("ditch.out", "w", stdout);
init();
solve();
return 0;
}