解题报告 之 UVA714 Copying Books

解题报告 之 UVA714 Copying Books

Description

Download as PDF

Before the invention of book-printing, it was very hard to make a copy of a book. All the contents had to be re-written by hand by so called scribers. The scriber had been given a book and after several months he finished its copy. One of the most famous scribers lived in the 15th century and his name was Xaverius Endricus Remius Ontius Xendrianus (Xerox). Anyway, the work was very annoying and boring. And the only way to speed it up was to hire more scribers.


Once upon a time, there was a theater ensemble that wanted to play famous Antique Tragedies. The scripts of these plays were divided into many books and actors needed more copies of them, of course. So they hired many scribers to make copies of these books. Imagine you have m books (numbered $1, 2, \dots, m$) that may have different number of pages ( $p_1, p_2, \dots, p_m$) and you want to make one copy of each of them. Your task is to divide these books among k scribes, $k \le m$. Each book can be assigned to a single scriber only, and every scriber must get a continuous sequence of books. That means, there exists an increasing succession of numbers $0 = b_0 <b_1 < b_2, \dots < b_{k-1} \le b_k = m$ such that i-th scriber gets a sequence of books with numbers between bi-1+1 and bi. The time needed to make a copy of all the books is determined by the scriber who was assigned the most work. Therefore, our goal is to minimize the maximum number of pages assigned to a single scriber. Your task is to find the optimal assignment.

Input 

The input consists of N cases. The first line of the input contains only positive integer N. Then follow the cases. Each case consists of exactly two lines. At the first line, there are two integers m and k,$1 \le k \le m \le 500$. At the second line, there are integers $p_1, p_2, \dots p_m$ separated by spaces. All these values are positive and less than 10000000.

Output 

For each case, print exactly one line. The line must contain the input succession $p_1, p_2, \dots p_m$ divided into exactly k parts such that the maximum sum of a single part should be as small as possible. Use the slash character (`/') to separate the parts. There must be exactly one space character between any two successive numbers and between the number and the slash.


If there is more than one solution, print the one that minimizes the work assigned to the first scriber, then to the second scriber etc. But each scriber must be assigned at least one book.

Sample Input 

2
9 3
100 200 300 400 500 600 700 800 900
5 4
100 100 100 100 100

Sample Output 

100 200 300 400 500 / 600 700 / 800 900
100 / 100 / 100 / 100 100

题目大意:将m个数用隔板分成k段,那么每段都有一个和,使得所有段中,最大的和有最小值,求怎么划分。

分析:最大值尽量小,让我想起了当年那一道配电脑的题目。。。所以很明确是二分,不过我二分始终把握不好条件的处理,到底是key+1还是key,还有是l>r还是r-l<sth. 。所以一直很纠结于这一点,这道题让我累计了一些这个经验。

不过应该怎么二分呢?每次制定一个目标值key,看看可不可能将最大值限定在key以内(转化为所有段的值在key以内),如果可以那么r=key(说不定还可以更小呢!),否则l=key。直到找出那个key。再确定分法就行了,我这里是从右边开始划分,尽量取,直到再去就超过key为止,这样保证Sum1、Sum2……依次最小。

上代码:
#include<iostream>
using namespace std;

long long num[510];
int m, k;
long long M;
int loc[510];
int j;

void biset(double l,double r)
{
	while (r-l>1e-6)
	{
		double key = (r + l) / 2;
		j = 0;
		int i = m - 1;
		double tem = 0;
		int seg = k;
		while (seg > 1)
		{
			tem += num[i];
			if (tem > key||i<seg-1)
			{
				seg--;
				tem = 0;
				loc[j++] = i;
			}
			else
			{
				i--;
			}
		}
		for (; i >= 0; i--)
			tem += num[i];

		if (tem > key)	l = key;
		else r = key;
	}

	j = 0;
	int i = m - 1;
	double tem = 0;
	int seg = k;
	while (seg > 1)
	{
		tem += num[i];
		if (tem > r || i<seg - 1)
		{
			seg--;
			tem = 0;
			loc[j++] = i;
		}
		else
		{
			i--;
		}
	}
}

int main()
{
	int kase;
	cin >> kase;
	while (kase--)
	{
		cin >> m >> k;
		M = 0;
		for (int i = 0; i < m; i++)
		{
			cin >> num[i];
			M += num[i];
		}
		biset(0, (double)M);
		int p = k-2;
		for (int i = 0; i <m; i++)
		{
			cout << num[i];
			if (i != m - 1)
				cout << " ";
			else
				cout << endl;
			if (i == loc[p])
			{
				cout << "/ ";
				p--;
			}
		}
	}
}

今天效率还将就,,,继续加油吧~


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值