网络流模板-(EdmondsKarp)-HDU-1532-Drainage Ditches

HDU - 1532 Drainage Ditches

Status

Description
Every time it rains on Farmer John’s fields, a pond forms over Bessie’s favorite clover patch. This means that the clover is covered by water for awhile and takes quite a long time to regrow. Thus, Farmer John has built a set of drainage ditches so that Bessie’s clover patch is never covered in water. Instead, the water is drained to a nearby stream. Being an ace engineer, Farmer John has also installed regulators at the beginning of each ditch, so he can control at what rate water flows into that ditch.
Farmer John knows not only how many gallons of water each ditch can transport per minute but also the exact layout of the ditches, which feed out of the pond and into each other and stream in a potentially complex network.
Given all this information, determine the maximum rate at which water can be transported out of the pond and into the stream. For any given ditch, water flows in only one direction, but there might be a way that water can flow in a circle.

Input
The input includes several cases. For each case, the first line contains two space-separated integers, N (0 <= N <= 200) and M (2 <= M <= 200). N is the number of ditches that Farmer John has dug. M is the number of intersections points for those ditches. Intersection 1 is the pond. Intersection point M is the stream. Each of the following N lines contains three integers, Si, Ei, and Ci. Si and Ei (1 <= Si, Ei <= M) designate the intersections between which this ditch flows. Water will flow through this ditch from Si to Ei. Ci (0 <= Ci <= 10,000,000) is the maximum rate at which water will flow through the ditch.

Output
For each case, output a single integer, the maximum rate at which water may emptied from the pond.

Sample Input
5 4
1 2 40
1 4 20
2 4 20
2 3 30
3 4 10

Sample Output
50

#include <cstdio>
#include <iostream>
#include <algorithm>
#include <cmath>
#include <cstring>
#include <queue>
#include <map>
#include <set>
#include <vector>
#include <string>
#include <time.h>
#define mem(a) memset(a,0,sizeof(a))
#define mem2(a) memset(a,-1,sizeof(a))
#define memf(a) memset(a,0x3f,sizeof(a))
#define mod 1000000007
#define mx 30000000
#define LL long long
#define INF 0x3f3f3f3f
using namespace std;

LL mp[205][205];
LL pre[205];
LL visited[205];
LL m,n;//n是节点的标号最大数

void update_residual_network(int u,int flow)
{
    while(pre[u]!=-1)
    {
        mp[pre[u]][u]-=flow;
        mp[u][pre[u]]+=flow;
        u=pre[u];
    }
}
int find_path_bfs(int s,int t)
{
    memset(visited,0,sizeof(visited));
    memset(pre,-1,sizeof(pre));
    visited[s]=1;
    int min=INF;
    queue<int> q;

//    while(!q.empty())q.pop();
    q.push(s);
    while(!q.empty())
    {
        int cur=q.front();
        q.pop();
        if(cur==t)   break;
        for(int i=1; i<=n; ++i)
            if( visited[i] == 0 && mp[cur][i] != 0)
            {
                q.push(i);
                min=(min<mp[cur][i]?min:mp[cur][i]) ;
                pre[i]=cur;
                visited[i]=1;
            }
    }
    if(pre[t]==-1) return 0;
    return min;
}
int edmonds_karp(int s,int t)
{
    int new_flow=0;
    int max_flow=0;
    do
    {
        new_flow = find_path_bfs(s,t);
        update_residual_network(t,new_flow);
        max_flow += new_flow;
    }
    while( new_flow != 0 );
    return max_flow;
}
int main()
{

    int x,y,z;
    while(cin>>m>>n)
    {
        mem(mp);
        for(int i=0; i<m; ++i)
        {
             cin>>x>>y>>z;
             if(x==y)continue;
             mp[x][y]==z;
        }
        cout<<edmonds_karp(1,n)<<endl;
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

渴鱼

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值