解题报告 之 POJ1021 Fibonacci Again

20 篇文章 2 订阅

解题报告 之 POJ1021 Fibonacci Again


Description

There are another kind of Fibonacci numbers: F(0) = 7, F(1) = 11, F(n) = F(n-1) + F(n-2) (n>=2). 
 

Input

Input consists of a sequence of lines, each containing an integer n. (n < 1,000,000). 
 

Output

Print the word "yes" if 3 divide evenly into F(n). 

Print the word "no" if not. 
 

Sample Input

     
     
0 1 2 3 4 5
 

Sample Output

     
     
no no yes no no no
 


题目大意:设新的斐波那契数列f(0)=7,f(1)=11, f(n)=f(n-1)+f(n-2),(n>=2)。输入n,判断f(n)是否能被3整除。

分析:首先明确是不可能直接加起来再求余数的。根据同余的基本性质,a=b+c,则a ≡ b+c (mod m),即可以转移取模的顺序,有:

f(n) ≡ f(n-1)+f(n-2) (mod m)

然后我们打表对f(n)取模3,依次处理下去即可。


上代码:

#include<iostream>
#include<algorithm>
using namespace std;

const int MAXN = 1e6 + 10;

int remain[MAXN];

void solve()
{
	remain[0] = 7 % 3; 
	remain[1] = 11 % 3;
	for(int i = 2; i < MAXN; i++)
		remain[i] = (remain[i - 1] + remain[i - 2]) % 3;
}

int main()
{
	int n;
	solve();
	while(cin >> n)
	{
		cout << (remain[n] == 0? "yes":"no") << endl;
	}
	return 0;
}

还有种更加诡异和巧妙的方法。就是打表过程中你会发现,余数的变化是1 2 0 2 2 1 0 1 || 1 2 0 2 2 1 0 1 ……,出现了循环节8,那么我们可以直接判断n%8+1是否等于3或者7。省去了打表的时间。


上代码:

#include<cstdio>
using namespace std;
int main()
{
	int n;
	while(scanf( "%d", &n ) == 1)
		printf( "%s\n", (n % 8 == 2 || n % 8 == 6) ? "yes" : "no" );
	return 0;
}


就这样一道水题飘过。

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值