XYOJ legal or not

1723: Legal or Not

时间限制: 1 Sec   内存限制: 32 MB
提交: 6   解决: 3
您该题的状态:已完成
[提交][状态][讨论版]

题目描述

ACM-DIY is a large QQ group where many excellent acmers get together. It is so harmonious that just like a big family. Every day,many "holy cows" like HH, hh, AC, ZT, lcc, BF, Qinz and so on chat on-line to exchange their ideas. When someone has questions, many warm-hearted cows like Lost will come to help. Then the one being helped will call Lost "master", and Lost will have a nice "prentice". By and by, there are many pairs of "master and prentice". But then problem occurs: there are too many masters and too many prentices, how can we know whether it is legal or not?We all know a master can have many prentices and a prentice may have a lot of masters too, it's legal. Nevertheless,some cows are not so honest, they hold illegal relationship. Take HH and 3xian for instant, HH is 3xian's master and, at the same time, 3xian is HH's master,which is quite illegal! To avoid this,please help us to judge whether their relationship is legal or not. Please note that the "master and prentice" relation is transitive. It means that if A is B's master ans B is C's master, then A is C's master.

输入

The input consists of several test cases. For each case, the first line contains two integers, N (members to be tested) and M (relationships to be tested)(2 <= N, M <= 100). Then M lines follow, each contains a pair of (x, y) which means x is y's master and y is x's prentice. The input is terminated by N = 0.TO MAKE IT SIMPLE, we give every one a number (0, 1, 2,..., N-1). We use their numbers instead of their names.

输出

For each test case, print in one line the judgement of the messy relationship.If it is legal, output "YES", otherwise "NO".

样例输入

4 3
0 1
1 2
2 3
3 3
0 1
1 2
2 0
0 1

样例输出

YES
NO

好像今天才算真正意义上的理解了并查集,并查集是无向图,拓扑序列是有向图,这点很重要,还要学习的还有很多啊,QAQ,

#include<stdio.h>    
#include<string.h>    
int degree[1000];    
int side[1000];    
int map[510][501],list,line;    
void TO()    
{    
    int i,j=0,k=100000,t;    
    for(i=1;i<=line;i++)    
    {    
        for(t=1;t<=line;t++)    
        {
        	if(degree[t]==0)//找没有前驱的点     
	        {    
	            k=t;    
	            break;    
	        }   
	        else k=100000;  
		}
        if(k==100000)//判断是否成环  
        {  
            printf("NO\n");  
            return ;  
        }  
        side[j++]=k;//记录该点     
        degree[k]=-1;//把该点去掉     
        for(int v=1;v<=line;v++) 
		{
			if(map[k][v])         //前驱与后面的连线消失  
				degree[v]--;
		   }     
    }    
   printf("YES\n");  
}    
int main()    
{    
    while(scanf("%d%d",&line,&list)!=EOF&&line)    
    {    
       if(line==0&&list==0)  
       break;  
        int j,a,b;    
        memset(map,0,sizeof(map));    
        memset(degree,0,sizeof(degree));    
        for(j=0;j<list;j++)    
        {    
            scanf("%d%d",&a,&b);   
            a=a+1;b=b+1;   
            if(map[a][b]==0)//防止出现重复如1,2;1,2这样的情况     
            {    
                map[a][b]=1;// 与前一步的关系;     
                degree[b]++;//前驱的数量     
            }    
        }    
        TO();    
    }    
    return 0;    
}    

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值