由Shape派生出的抽象基类

本文介绍如何创建一个抽象基类Shape,并从该类派生出Circle、Rectangle和Triangle三个子类,用于计算并输出不同形状的面积。程序要求在定义对象时提供必要的尺寸参数,并保留两位小数。
摘要由CSDN通过智能技术生成

Description

编写一个程序,声明抽象基类Shape,由它派生出3个派生类: Circle(圆形)、Rectangle(矩形)、Triangle(三角形),用一个函数printArea分别输出以上三者的面积(结果保留两位小数),3个图形的数据在定义对象时给定。

Input

圆的半径
矩形的边长
三角形的底与高

Output

圆的面积
矩形的面积
三角形的面积

Sample Input

12.6
4.5 8.4
4.5 8.4

Sample Output

area of circle = 498.76
area of rectangle = 37.80
area of triangle = 18.90

Code

#include <iostream>
#include <iomanip>
using namespace std;
class Shape
{
public:
    virtual double area()=0;//定义一个纯虚函数
};
void printArea(Shape &shape)
{
    cout<<shape.area()<<endl;
}
class Circle:public Shape
{
protected:
    double r;
public:
    Circle(double a):r(a){}
    virtual double area()
    {
        return (3.14159*r*r);
    }
};
class Rectangle:public Shape
{
protected:
    double a;
    double b;
public:
    Rectangle(double x,double y):a(x),b(y){}
    virtual double area()
    {
        return (a*b);
    }
};
class Triangle:public Shape
{
protected:
    double w;
    double h;
public:
    Triangle(double x,double y):w(x),h(y){}
    virtual double area()
    {
        return (w*h/2);
    }

};
int main()

{

    float r,a,b,w,h;

    cout<<fixed<<setprecision(2);

    cin>>r;

    Circle circle(r);

    cout<<"area of circle = ";

    printArea(circle);

    cin>>a>>b;

    Rectangle rectangle(a,b);

    cout<<"area of rectangle = ";

    printArea(rectangle);

    cin>>w>>h;

    Triangle triangle(w,h);

    cout<<"area of triangle = ";

    printArea(triangle);

    return 0;

}




评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值