hdu2838 cow sorting

Problem Description
Sherlock's N (1 ≤ N ≤ 100,000) cows are lined up to be milked in the evening. Each cow has a unique "grumpiness" level in the range 1...100,000. Since grumpy cows are more likely to damage Sherlock's milking equipment, Sherlock would like to reorder the cows in line so they are lined up in increasing order of grumpiness. During this process, the places of any two cows (necessarily adjacent) can be interchanged. Since grumpy cows are harder to move, it takes Sherlock a total of X + Y units of time to exchange two cows whose grumpiness levels are X and Y.

Please help Sherlock calculate the minimal time required to reorder the cows.
 

Input
Line 1: A single integer: N
Lines 2..N + 1: Each line contains a single integer: line i + 1 describes the grumpiness of cow i.
 

Output
Line 1: A single line with the minimal time required to reorder the cows in increasing order of grumpiness.
 

Sample Input
  
  
3 2 3 1
 

Sample Output
  
  
7
跟sort it一类的 凡是交换相邻数达到按顺序排列都是求逆序数 所以这次是(X+Y)
这次要带上数值了 所以建了结构体树状数组 一个记录这个数字有没有出现过 另一个记录前多少项的值。
#include <iostream>
#include<string.h>
#include<stdio.h>
using namespace std;
const int maxn=100005;
int n;
struct cow
{
    int num;
    long long sum;
}a[maxn];
int lowbit(int i)
{
    return i&(-i);
}
void update(int i, int x, int y)
{
    while(i<=n)
    {
        a[i].num+=y;
        a[i].sum+=x;
        i=i+lowbit(i);
    }
}
long long  query_num(int i) 
{
    long long  ans=0;
    while(i>0)
    {
        ans+=a[i].num;
        i-=lowbit(i);
    }
    return ans;
}
long long query_sum(int i)
{
    long long ans=0;
    while(i>0)
    {
        ans+=a[i].sum;
        i-=lowbit(i);
    }
    return ans;
}
int main()
{
    int x;
    while(cin>>n)
    {
        long long ans=0;
        memset(a,0,sizeof(a));
        for(int i=1;i<=n;i++)
        {
            scanf("%d",&x);
            update(x,x,1);
            long long k1=i-query_num(x);  //i位置之前比x大的数有多少
            if(k1!=0)
            {
                long long k2=query_sum(n)-query_sum(x); //所有前n个数的和减去比a小的数的和 因为 a是刚输入的 前n-1个数都是在她之前插入的 所以如果比她大就应该交换 
                ans+=k1*x+k2; 
            }

        }
        cout<<ans<<endl;
    }

    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值