HDU 2473 并查集的删除

http://acm.split.hdu.edu.cn/showproblem.php?pid=2473

Junk-Mail Filter

Time Limit: 15000/8000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 8885    Accepted Submission(s): 2830


Problem Description
Recognizing junk mails is a tough task. The method used here consists of two steps:
1) Extract the common characteristics from the incoming email.
2) Use a filter matching the set of common characteristics extracted to determine whether the email is a spam.

We want to extract the set of common characteristics from the N sample junk emails available at the moment, and thus having a handy data-analyzing tool would be helpful. The tool should support the following kinds of operations:

a) “M X Y”, meaning that we think that the characteristics of spam X and Y are the same. Note that the relationship defined here is transitive, so
relationships (other than the one between X and Y) need to be created if they are not present at the moment.

b) “S X”, meaning that we think spam X had been misidentified. Your tool should remove all relationships that spam X has when this command is received; after that, spam X will become an isolated node in the relationship graph.

Initially no relationships exist between any pair of the junk emails, so the number of distinct characteristics at that time is N.
Please help us keep track of any necessary information to solve our problem.
 

Input
There are multiple test cases in the input file.
Each test case starts with two integers, N and M (1 ≤ N ≤ 10 5 , 1 ≤ M ≤ 10 6), the number of email samples and the number of operations. M lines follow, each line is one of the two formats described above.
Two successive test cases are separated by a blank line. A case with N = 0 and M = 0 indicates the end of the input file, and should not be processed by your program.
 

Output
For each test case, please print a single integer, the number of distinct common characteristics, to the console. Follow the format as indicated in the sample below.
 

Sample Input
  
  
5 6 M 0 1 M 1 2 M 1 3 S 1 M 1 2 S 3 3 1 M 1 2 0 0
 

Sample Output
  
  
Case #1: 3 Case #2: 2

设虚父结点删除节点



其实就是找个点顶替要删除掉的点
题目大意:有n封邮件现在要将其含有相同的特征的放在一起,M X Y代表X,Y具有相同的特征,S Y代表Y被错判了现在问你这两种操作完成后还有多少种的信,注意特征可以传递 X Y 有相同特征Y Z有相同的特征,则X Y Z同时具有相同的特征。如果X Y Z中有一个被误判这剩下的两个仍然具有相同的特征。需要注意的是当1和2并上,2和3并上,2被删除后,1与3是依然并在一起的。


#include <iostream>
#include <cstring>
#include <cstdio>
#include <algorithm>
#include <set>
#include <string>
using namespace std;


//学会了并查集的删除操作,找个点顶替要删除的点,就行了。  
//引入虚拟节点,当合并的时候都把节点丢给虚拟节点,这样当删除节点的时候,只要把它自己指向一个没用过的虚拟节点就可以了
const int maxn=1e6+5;
int fa[maxn];//虚拟节点(设置这个是用来找根节点的) 
int id[maxn];//固定根节点
set <int> s;
int find(int x){return fa[x]==x?fa[x]:fa[x]=find(fa[x]);}
int main()
{
	int n,m;
	int cnt=0;
	int ans;
	while (~scanf("%d%d",&n,&m),n||m)//n例子数, m操作数 
	{
		for (int i=0;i<maxn;i++)	fa[i]=i;
		for (int i=0;i<n;i++)	id[i]=i;
		ans=n;//删除的都放到n后面,这样等会判断就不会重复 
		while (m--)
		{
			char str[5];
			int a,b;
			scanf("%s",str);
			if (str[0]=='M')
			{
				scanf("%d%d",&a,&b);
				int X=find(id[a]);
				int Y=find(id[b]);
				if (X!=Y) fa[X]=Y;//把a的根节点指向b的根节点 
			}
			else
			{
				scanf("%d",&a);
				id[a]=ans++;//删除就是把根节点指向n之后的地方 
			}
		}
		s.clear();
		for (int i=0;i<n;i++)
		{
			s.insert(find(id[i]));
		}
		printf ("Case #%d: %d\n",++cnt,s.size());
	}
	return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值