Description
编写一个程序,实现链表的各种基本运算(假设顺序表的元素类型为char),主函数已给出,请补充每一种方法。
1、初始化单链表L;
2、采用尾插法插入一个元素;
3、输出单链表L;
4、输出单链表L的长度;
5、判断单链表L是否为空;
6、输出单链表L的第三个元素;
7、输出元素a的位置;
8、在第四个元素位置插入元素f;
9、输出单链表L;
10、删除L的第三个元素;
11、输出单链表L;
12、释放单链表L;
数据元素类型定义为
typedef char ElemType;
顺序表的定义为
int main()
{
SqList *L;
InitList(L); //初始化单链表
ElemType a,b,c,d,e;
scanf("%c %c %c %c %c%*c",&a,&b,&c,&d,&e);
Insert(L,a);
Insert(L,b);
Insert(L,c);
Insert(L,d);
Insert(L,e); //使用尾插法插入元素a,b,c,d,e
Print(L); //输出单链表
PrintLength(L); //输出单链表长度
if(SqNull(L))
printf("单链表不为空\n");
else printf("单链表为空\n"); //判断单链表是否为空
PrintData(L,3); //输出第三个元素
printf("元素a的位置:%d\n",Find(L,a)); //输出元素a的位置
ElemType f;
scanf("%c",&f);
Insertinto(L,4,f); //将f插入到第四个位置
Print(L); //输出单链表
Delete(L,3); //删除第三个元素
Print(L); //输出单链表
free(L); //释放内存
return 0;
}
Input
第一行输入五个元素a,b,c,d,e;接下来输入元素f;请根据题目编写算法。
Output
Sample Input
1 2 3 4 5
6
Sample Output
1 2 3 4 5
5
单链表不为空
3
元素a的位置:1
1 2 3 6 4 5
1 2 6 4 5
HINT
请使用C++编译并提交
【AC代码】:
#include <malloc.h>
#include <stdio.h>
typedef char ElemType;
#define SizeMax 50
typedef struct Node
{
ElemType data;
struct Node *next;
} SqList;
void InitList(SqList *&L)
{
L=(SqList *)malloc(sizeof(SqList));
L->next=NULL;
}
void Insert(SqList *&L,char x)
{
/**尾插法建表*/
SqList *s,*p;
p=L;
while(p->next!=NULL)
p=p->next;
s=p;
p=(SqList *)malloc(sizeof(SqList));
p->data=x;
s->next=p;
p->next=NULL;
}
void Print(SqList *&L)
{
SqList *p=L->next;
while(p!=NULL)
{
printf("%c ",p->data);
p=p->next;
}
printf("\n");
}
void PrintLength(SqList *&L)
{
int n=0;
SqList *p=L;
while(p->next!=0)
{
n++;
p=p->next;
}
printf("%d\n",n);
}
bool SqNull(SqList *&L)
{
if(L->next==NULL)
return false;
else
return true;
}
bool PrintData(SqList *&L,int n)
{
int i=0;
SqList *p=L;
while(i<n&&p!=NULL)
{
i++;
p=p->next;
}
if(p==NULL)
return false;
printf("%c\n",p->data);
return true;
}
int Find(SqList *&L,ElemType x)
{
int i;
SqList *p=L;
while(p!=NULL)
{
i++;
if(p->data==x)
return i+1;
p=p->next;
}
}
bool Insertinto(SqList *&L,int n, ElemType x)
{
int i=0;
SqList *p=L,*s;
while(p!=NULL&&i<n-1)
{
i++;
p=p->next;
}
if(p==NULL)
return false;
s=(SqList *)malloc(sizeof(SqList));
s->data=x;
s->next=p->next;
p->next=s;
return true;
}
bool Delete(SqList *&L,int n)
{
int i=0;
SqList *p=L,*s;
while(p!=NULL&&i<n-1)
{
i++;
p=p->next;
}
if(p==NULL)
return false;
s=p->next;
if(s==NULL)
return false;
p->next=s->next;
free(s);
return true;
}
int main()
{
SqList *L;
InitList(L); //初始化单链表
ElemType a,b,c,d,e;
scanf("%c %c %c %c %c%*c",&a,&b,&c,&d,&e);
Insert(L,a);
Insert(L,b);
Insert(L,c);
Insert(L,d);
Insert(L,e); //使用尾插法插入元素a,b,c,d,e
Print(L); //输出单链表
PrintLength(L); //输出单链表长度
if(SqNull(L))
printf("单链表不为空\n");
else
printf("单链表为空\n"); //判断单链表是否为空
PrintData(L,3); //输出第三个元素
printf("元素a的位置:%d\n",Find(L,a)); //输出元素a的位置
ElemType f;
scanf("%c",&f);
Insertinto(L,4,f); //将f插入到第四个位置
Print(L); //输出单链表
Delete(L,3); //删除第三个元素
Print(L); //输出单链表
free(L); //释放内存
return 0;
}