PAT B1028. 人口普查

某城镇进行人口普查,得到了全体居民的生日。现请你写个程序,找出镇上最年长和最年轻的人。

这里确保每个输入的日期都是合法的,但不一定是合理的——假设已知镇上没有超过200岁的老人,而今天是2014年9月6日,所以超过200岁的生日和未出生的生日都是不合理的,应该被过滤掉。

输入格式:

输入在第一行给出正整数N,取值在(0, 105];随后N行,每行给出1个人的姓名(由不超过5个英文字母组成的字符串)、以及按“yyyy/mm/dd”(即年/月/日)格式给出的生日。题目保证最年长和最年轻的人没有并列。

输出格式:

在一行中顺序输出有效生日的个数、最年长人和最年轻人的姓名,其间以空格分隔。

输入样例:
5
John 2001/05/12
Tom 1814/09/06
Ann 2121/01/30
James 1814/09/05
Steve 1967/11/20
输出样例:
3 Tom John
题解

#include<cstdio>
#include<iostream>
using namespace std;
struct person {
	char name[20];
	int year;
	int month;
	int day;
}youngest,oldest,left,right,temp;
//比b年龄大为1,同为0,小为-1
int judge(person a, person b) {
	if (a.year != b.year) {
		if (a.year > b.year)
			return -1;
		else
			return 1;
	}
	else if (a.month != b.month) {
		if (a.month > b.month)
			return -1;
		else
			return 1;
	}
	else if (a.day != b.day) {
		if (a.day > b.day)
			return -1;
		else
			return 1;
	}
	else
		return 0;
}
int main() {
	int n, count = 0;
	youngest.year = ::left.year = 1814;
	oldest.year = ::right.year = 2014;
	youngest.month = oldest.month = ::left.month = ::right.month = 9;
	youngest.day = oldest.day = ::left.day = ::right.day = 6;
	cin >> n;
	for (int i = 0; i < n; i++) {
		scanf("%s %d/%d/%d", temp.name, &temp.year, &temp.month, &temp.day);
		//不比左边界大不比右边界小即为合法
		if (judge(temp, ::left) !=1 && judge(temp, ::right) !=-1) {
			count++;
			if (judge(temp, oldest) == 1)
				oldest = temp;
			if (judge(temp, youngest) == -1)
				youngest = temp;
		}
	}
	if (count == 0)
		printf("%d", count);
	else
		printf("%d %s %s", count, oldest.name, youngest.name);
	return 0;
}

//这题要注意合法的人为0时只输出0,不然会格式错误



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值