杭电1053 Entropy

题目内容:

Problem Description
An entropy encoder is a data encoding method that achieves lossless data compression by encoding a message with “wasted” or “extra” information removed. In other words, entropy encoding removes information that was not necessary in the first place to accurately encode the message. A high degree of entropy implies a message with a great deal of wasted information; english text encoded in ASCII is an example of a message type that has very high entropy. Already compressed messages, such as JPEG graphics or ZIP archives, have very little entropy and do not benefit from further attempts at entropy encoding.

English text encoded in ASCII has a high degree of entropy because all characters are encoded using the same number of bits, eight. It is a known fact that the letters E, L, N, R, S and T occur at a considerably higher frequency than do most other letters in english text. If a way could be found to encode just these letters with four bits, then the new encoding would be smaller, would contain all the original information, and would have less entropy. ASCII uses a fixed number of bits for a reason, however: it’s easy, since one is always dealing with a fixed number of bits to represent each possible glyph or character. How would an encoding scheme that used four bits for the above letters be able to distinguish between the four-bit codes and eight-bit codes? This seemingly difficult problem is solved using what is known as a “prefix-free variable-length” encoding.

In such an encoding, any number of bits can be used to represent any glyph, and glyphs not present in the message are simply not encoded. However, in order to be able to recover the information, no bit pattern that encodes a glyph is allowed to be the prefix of any other encoding bit pattern. This allows the encoded bitstream to be read bit by bit, and whenever a set of bits is encountered that represents a glyph, that glyph can be decoded. If the prefix-free constraint was not enforced, then such a decoding would be impossible.

Consider the text “AAAAABCD”. Using ASCII, encoding this would require 64 bits. If, instead, we encode “A” with the bit pattern “00”, “B” with “01”, “C” with “10”, and “D” with “11” then we can encode this text in only 16 bits; the resulting bit pattern would be “0000000000011011”. This is still a fixed-length encoding, however; we’re using two bits per glyph instead of eight. Since the glyph “A” occurs with greater frequency, could we do better by encoding it with fewer bits? In fact we can, but in order to maintain a prefix-free encoding, some of the other bit patterns will become longer than two bits. An optimal encoding is to encode “A” with “0”, “B” with “10”, “C” with “110”, and “D” with “111”. (This is clearly not the only optimal encoding, as it is obvious that the encodings for B, C and D could be interchanged freely for any given encoding without increasing the size of the final encoded message.) Using this encoding, the message encodes in only 13 bits to “0000010110111”, a compression ratio of 4.9 to 1 (that is, each bit in the final encoded message represents as much information as did 4.9 bits in the original encoding). Read through this bit pattern from left to right and you’ll see that the prefix-free encoding makes it simple to decode this into the original text even though the codes have varying bit lengths.

As a second example, consider the text “THE CAT IN THE HAT”. In this text, the letter “T” and the space character both occur with the highest frequency, so they will clearly have the shortest encoding bit patterns in an optimal encoding. The letters “C”, “I’ and “N” only occur once, however, so they will have the longest codes.

There are many possible sets of prefix-free variable-length bit patterns that would yield the optimal encoding, that is, that would allow the text to be encoded in the fewest number of bits. One such optimal encoding is to encode spaces with “00”, “A” with “100”, “C” with “1110”, “E” with “1111”, “H” with “110”, “I” with “1010”, “N” with “1011” and “T” with “01”. The optimal encoding therefore requires only 51 bits compared to the 144 that would be necessary to encode the message with 8-bit ASCII encoding, a compression ratio of 2.8 to 1.
 

Input
The input file will contain a list of text strings, one per line. The text strings will consist only of uppercase alphanumeric characters and underscores (which are used in place of spaces). The end of the input will be signalled by a line containing only the word “END” as the text string. This line should not be processed.
 

Output
For each text string in the input, output the length in bits of the 8-bit ASCII encoding, the length in bits of an optimal prefix-free variable-length encoding, and the compression ratio accurate to one decimal point.
 

Sample Input
  
  
AAAAABCD THE_CAT_IN_THE_HAT END
 

Sample Output
  
  
64 13 4.9 144 51 2.8

题目大意:

对于给定的字符串,对其进行重编码压缩,即使用新的二进制编码来代替改字符,求编码的最短长度


题目分析:

对于编码类的问题,其实可以归为使用huffman编码的贪心问题,作为一种成熟的算法,掌握了huffman编码的核心,即可以轻松解决这道问题

但可以说是由于偷懒不想写huffman的复杂代码,我发现这道题虽然用的是huffman的贪心思想,但其实并不用真正构造huffman树,使用优先队列即可解决

我的方法是

对于给定的数据反复将其递增排序,每次最小的两个数合并为合并为一个新的数,同时队列长度减一,并把之前的数值加入总长度sum中,这就完成了huffman树的实际构造

因为构造huffman树的目的无非是找出各个字符重新编码后的长度,而我发现在此种合并过程中,各个字符在每次引用中其值已准确加入到总sum中,因而并不需要把huffman完全写出来即可解决问题


题目代码:

#include<stdio.h>
#include<iostream>
#include<algorithm>
#include<string.h>

using namespace std;

int nodes[27];

int huffman(int *t,int l)
{
    int sum=0;
    t=nodes+27-l;
    for(int i=0;i<l-1;i++)
    {
        t[i+1]+=t[i];
        sum+=t[i+1];
        sort(t+i+1,t+l);
    }
    return sum;
}

char str[1005];
int raw,huf;

int main()
{
    while(scanf("%s",str))
    {
        if(strcmp(str,"END")==0)
            exit(0);
        for(int i=0;i<27;i++)
            nodes[i]=0;
        raw=huf=0;
        int l=strlen(str);
        for(int i=0;i<l;i++)
        {
            raw+=8;
            if(str[i]=='_')
                nodes[26]++;
            else
                nodes[str[i]-'A']++;
        }
        sort(nodes,nodes+27);
        for(int i=0;i<27;i++)
            if(nodes[i]!=0)
            {
                l=27-i;
                break;
            }
            if(l==1)
            {
                printf("%d %d 8.0\n",nodes[26]*8,nodes[26]);
                continue;
            }
            huf=huffman(nodes,l);
            printf("%d %d %.1lf\n",raw,huf,1.0*raw/huf);
    }
    return 0;
}
解题评价:

这道题的亮点在于需要了解huffman原理解决问题,而对于huffman的运用上却又十分灵活,是一道比较特别的贪心问题

当前水平评分:5

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值