poj 3176 Cow Bowling动态规划

10 篇文章 0 订阅
Cow Bowling
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 12462 Accepted: 8219

Description

The cows don't use actual bowling balls when they go bowling. They each take a number (in the range 0..99), though, and line up in a standard bowling-pin-like triangle like this:

          7



        3   8



      8   1   0



    2   7   4   4



  4   5   2   6   5
Then the other cows traverse the triangle starting from its tip and moving "down" to one of the two diagonally adjacent cows until the "bottom" row is reached. The cow's score is the sum of the numbers of the cows visited along the way. The cow with the highest score wins that frame.

Given a triangle with N (1 <= N <= 350) rows, determine the highest possible sum achievable.

Input

Line 1: A single integer, N

Lines 2..N+1: Line i+1 contains i space-separated integers that represent row i of the triangle.

Output

Line 1: The largest sum achievable using the traversal rules

Sample Input

5
7
3 8
8 1 0
2 7 4 4
4 5 2 6 5

Sample Output

30

Hint

Explanation of the sample:

          7

         *

        3   8

       *

      8   1   0

       *

    2   7   4   4

       *

  4   5   2   6   5
The highest score is achievable by traversing the cows as shown above.
这道题意思很简单就是给你一个三角形的矩阵[i][j]只能走向自己的下面[i+1][j]和右下面[i+1][j+1]并且权值相加
求走完所有的行最大的权值,这道题同样可以通过我的吃豆机器人解释吃豆机器人链接
很好的解释了状态方程的由来
#include<stdio.h>
#include<iostream>
#include<cstring>
using namespace std;
int dp[355][355];
int max(int a,int b)
{
	return a>b?a:b;
}
int main()
{
	int i,j,n,num;
	while(scanf("%d",&n)!=EOF)
	{	memset(dp,0,sizeof(dp));
		num=0;
		for(i=1;i<=n;i++)
			for(j=1;j<=i;j++)
				scanf("%d",&dp[i][j]);
	
		for(i=1;i<=n;i++)
			for(j=1;j<=i;j++)
			{
				dp[i][j]+=max(dp[i-1][j-1],dp[i-1][j]);
					if(dp[i][j]>num)
						num=dp[i][j];
			}
			printf("%d\n",num);
	}
return 0;
}
另一道题poj1163也是这个思路,代码不用改都能通过 点击打开链接

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值