动态规划 DAG问题uva 437 The Tower of Babylon

1 篇文章 0 订阅


The Tower of Babylon

Perhaps you have heard of the legend of the Tower of Babylon. Nowadays many details of this talehave been forgotten. So now, in line with the educational nature of this contest, we will tell you thewhole story:

The babylonians had n types of blocks, and an unlimited supply of blocks of each type. Each type-iblock was a rectangular solid with linear dimensionstex2html_wrap_inline32 . A block could be reoriented so thatany two of its three dimensions determined the dimensions of the base and the other dimension was the height.They wanted to construct the tallest tower possible by stacking blocks. The problem was that, inbuilding a tower, one block could only be placed on top of another block as long as the two basedimensions of the upper block were both strictly smaller than the corresponding base dimensions ofthe lower block. This meant, for example, that blocks oriented to have equal-sized bases couldn't bestacked.

Your job is to write a program that determines the height of the tallest tower the babylonians canbuild with a given set of blocks.

Input and Output

The input file will contain one or more test cases. The first line of each test case contains an integern, representing the number of different blocks in the following data set. The maximum value forn is 30.Each of the next n lines contains three integers representing the valuestex2html_wrap_inline40 ,tex2html_wrap_inline42 andtex2html_wrap_inline44 .

Input is terminated by a value of zero (0) for n.

For each test case, print one line containing the case number (they are numbered sequentiallystarting from 1) and the height of the tallest possible tower in the format "Casecase: maximum height = height"

Sample Input

1
10 20 30
2
6 8 10
5 5 5
7
1 1 1
2 2 2
3 3 3
4 4 4
5 5 5
6 6 6
7 7 7
5
31 41 59
26 53 58
97 93 23
84 62 64
33 83 27
0

Sample Output

Case 1: maximum height = 40
Case 2: maximum height = 21
Case 3: maximum height = 28
Case 4: maximum height = 342
这道题的主要意思是有若干种类的立方体,每种有无限个个数可以选且上面的立方体要长和宽都小于下面的个体求最大的高度
#include<iostream>
#include<stdio.h>
#include<cstring>
#include<algorithm>
using namespace std;
struct box
{
	int length;
	int width;
	int heighth;
}point[300];
int dp[300],l=0;
bool operator <(const box &a,const box &b)
{ 
    return a.length<b.length;
}
int main()
{
	int i,j,T,temp[5],k,m,ans;
	while(scanf("%d",&T)&&T!=0)
	{

ans=0;
		memset(dp,0,sizeof(dp));
		memset(point,0,sizeof(point));
		for(i=1;i<=6*T;i)
		{	memset(temp,0,sizeof(temp));
			scanf("%d%d%d",&temp[1],&temp[2],&temp[3]);
			for(j=1;j<=3;++j)
				for(k=1;k<=3;++k)
					for(m=1;m<=3;++m)
					{
						if(j!=k&&j!=m&&k!=m)///这里把一个立方体的边数进行全排列
						{
							
							point[i].length=temp[j];
							point[i].width=temp[k];
							point[i].heighth=temp[m];
							i++;
						}
					}
		}
		sort(point,point+6*T+1);
	int max ,ans=0;

		for(i=1;i<=6*T;i++)
		{
			max=0;
			for(j=i-1;j>=1;j--)
			{
				if(point[i].length>point[j].length&&point[i].width>	point[j].width)
					if(dp[j]>max)
						max=dp[j];//每次都把dp更新
			}
			dp[i]=max+point[i].heighth;
			if(ans<dp[i])
				ans=dp[i];
		}
		printf("Case %d: maximum height = %d\n",++l,ans);
	}
	return 0;
}
















  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值