2021-07-06-C++学习笔记

本文介绍了一个简单的程序,用于检查宇航员候选人的视力(100%清晰度)和身高(62-75英寸)是否符合标准。输入视力百分比和身高后,程序会输出'passed'或'failed'

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

Along with other physical health requirements, astronaut candidates must have perfect vision (100%) and their height must be between 62 and 75 inches. Write a program that accordingly takes the vision percentage and height (in inches) as an input and prints “passed” if given conditions are satisfied and “failed” if otherwise.

Sample Input
100
80

Sample Output
failed

//my code

#include <iostream>
using namespace std;

int main() {
    
    int vision;
    cin >> vision;
    
    int height;
    cin >> height;
    if (vision/100==1 && height > 62 && height < 75){
    
    cout<<"passed";
    }
    else 
    cout<<"failed";
	return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

萱帧闯江湖

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值