字符串处理Keep Deleting

Assume that string A is the substring of string B if and only if we can find A in B, now we have a string A and another string B, your task is to find a A in B from B's left side to B's right side, and delete it from B till A is not a substring of B, then output the number of times you do the delete.

There are only letters(A-Z, a-z) in string A and B

This problem contains multiple test cases. Each case contains two line, the first line is string A, the second line is string B, the length of A is less than 256, the length of B is less than 512000

Print exactly one line with the number of times you do the delete for each test case.

Sample Input

abcd
abcabcddabcdababcdcd

Sample Output

5
Hint
abcabcddabcdababcdcd delete=0
abcdabcdababcdcd     delete=1
abcdababcdcd         delete=2
ababcdcd             delete=3
abcd                 delete=4
                     delete=5

 

意思是给你两个字符串A, B删掉B内存在的A串,删掉后就会连接起来了,看最后要删几次。

捉狂了,就是要用数组模拟栈,如果长度够是了lena的话看是否能删不能继续但是下一是所在字符串的后lena这段时候合适,能就删,

#include <stdio.h>
#include <string.h>
#include <vector>
#include <algorithm>
using namespace std;
const int base =512010;
char s[base],A[base],B[base],c[base];
int main()
{
   while(~scanf("%s%s", A, B))
   {
    int la=strlen(A);
    int lb=strlen(B);
    memset(s, 0, sizeof(s));
    int cout=0,k=0;
    for(int i =0; i<lb; i++)
    {
       s[k++]=B[i];
       if(k>=la)
       {
           s[k]='\0';
           if(strcmp(s+k-la,A)==0) //就是看在s串里面最后的la个这个子串是否和A相同
           {
               k-=la;
               cout++;
           }
       }
    }
    printf("%d\n", cout);
   }
    return 0;
}


 

 

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值