1034: 素数问题

Description

编写一个程序判断一个数是否为素数

Input

正整数N 不超过2000

Output

1或0(其中1表示此数为素数,0为表示为不是素数)

Sample Input

5

Sample Output

1

#include<iostream>
#include<math.h>
using namespace std;
int main()
{
    int i,j;
    int b;
    cin>>i;
      b=sqrt(i);
        int flag=0;
        for(j=2; j<=b; j++)
        {
            if(i%j==0)
            {
                flag=1;
                break;
            }
        }
         if(flag==0)
        cout<<"1";
        else
            cout<<"0";


}

此题由1030题简单修改而来。

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值