sdut_java_分数加减法

分数加减法

Time Limit: 1000MS  Memory Limit: 65536KB
Problem Description

编写一个C程序,实现两个分数的加减法

Input

输入包含多行数据
每行数据是一个字符串,格式是"a/boc/d"。

其中a, b, c, d是一个0-9的整数。o是运算符"+"或者"-"。

数据以EOF结束
输入数据保证合法
 

Output
对于输入数据的每一行输出两个分数的运算结果。
注意结果应符合书写习惯,没有多余的符号、分子、分母,并且化简至最简分数
Example Input
1/8+3/8
1/4-1/2
1/3-1/3
Example Output
1/2
-1/4
0
import java.util.Scanner;

public class Main {
	
	public static void main(String[] args) {
		
		Scanner in = new Scanner(System.in);
		while( in.hasNext() ){
			
			String str = in.next();
			char[]s = str.toCharArray();
			int fk = 0; 
			int fh = 0;
			int i;
			for( i=0; i<str.length(); i++ ){
		    	if( s[i]=='+' ){
		    		fk = i;
		    		fh = 1;
		    		break;
		         }
		    	else if( s[i]=='-' ){
		    		fk = i;
		    		fh = 2;
		    		break;
		    	}
		    }	
			
			String s1 = str.substring(0, fk);
		    String s2 = str.substring(fk+1, str.length());
		    String []p = s1.split("\\/"); 
		    String []q = s2.split("\\/");			
		    int a = Integer.parseInt(p[0]); 
		    int b = Integer.parseInt(p[1]);
		    int c = Integer.parseInt(q[0]);
		    int d = Integer.parseInt(q[1]);			
			Fs fs1 = new Fs(a, b);
			Fs fs2 = new Fs(c, d);
			
			Fs result = new Fs();
						    
			if( fh==1 )
				result = fs1.add(fs2);		
			if( fh==2 )
				result = fs1.sub(fs2);	
			if( (result.fz%result.fm) == 0 )
				System.out.println(result.fz/result.fm);
			else
				System.out.println(result.fz+"/"+result.fm);	
		}
		in.close();
	}
}
class Fs {
	
	int fz;
	int fm;
	
	public Fs( int fz, int fm ){
		this.fz = fz;
		this.fm = fm;
	}
	
	public Fs(){}
	
	public Fs add( Fs fs ){
		int newFz = fz*fs.fm + fm*fs.fz;
		int newFm = fm*fs.fm;
		int gys = gys(newFz,newFm);
		return new Fs(newFz/gys, newFm/gys);
	}

	public Fs sub( Fs fs ){
		int newFz = fz*fs.fm - fm*fs.fz;
		int newFm = fm*fs.fm;
		int gys = gys(newFz,newFm); 
		return new Fs(newFz/gys, newFm/gys);
	}
	
	public int gys( int a, int b ){

		int m = Math.max(Math.abs(a), Math.abs(b));
		int n = Math.min(Math.abs(a), Math.abs(b));
		int r;
		while( n!=0 ){
			r = m%n;
			m = n;
			n = r;
		}			
		return m;
	}
}

  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值