sdut_java_区域内点的个数

区域内点的个数

Time Limit: 1000MS  Memory Limit: 65536KB
Problem Description
X晚上睡不着的时候不喜欢玩手机,也不喜欢打游戏,他喜欢数星星。
Input
 多组输入。
每组先输入一个整数N(N <= 10000),接着输入两个点代表矩形的左下点B(x,y)和右上点T(x,y),然后输入N个(X,Y)代表N颗星星。问有多少颗星星在窗子内部,在窗边上的不计。
Output
 输出一个整数,代表有多少颗星星在窗子内部。
Example Input
3
0 1
3 4
1 1
2 2
3 3
Example Output
1
import java.text.DecimalFormat;
import java.util.Scanner;

public class Main {
	
	public static void main(String[] args) {
		
		Scanner in = new Scanner(System.in);
		while( in.hasNext() ){
			int t = in.nextInt();
			int x1 = in.nextInt();
			int y1 = in.nextInt();
			int x2 = in.nextInt();
			int y2 = in.nextInt();
			int cnt = 0;
			Point p1 = new Point(x1, y1);
			Point p2 = new Point(x2, y2);
			for( int i=0; i<t; i++ ){
				Point p = new Point(in.nextInt(),in.nextInt());
				if( p.isRight(p1, p2))
					cnt++;
			}
			System.out.println(cnt);
		}
		in.close();
	}
}

class Point {
	int x, y;
	
	public Point ( int x, int y ){
		this.x = x;
		this.y = y;
	}
	
	public boolean isRight( Point p1, Point p2 ){
		boolean f = false;
		if( x>p1.x&&x<p2.x &&y>p1.y&&y<p2.y )
			f = true;
		return f;
	}
}

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值