01-复杂度2 Maximum Subsequence Sum (25分)

Given a sequence of KK integers { N_1N1N_2N2, ..., N_KNK }. A continuous subsequence is defined to be { N_iNiN_{i+1}Ni+1, ..., N_jNj } where 1 \le i \le j \le K1ijK. The Maximum Subsequence is the continuous subsequence which has the largest sum of its elements. For example, given sequence { -2, 11, -4, 13, -5, -2 }, its maximum subsequence is { 11, -4, 13 } with the largest sum being 20.

Now you are supposed to find the largest sum, together with the first and the last numbers of the maximum subsequence.

Input Specification:

Each input file contains one test case. Each case occupies two lines. The first line contains a positive integer KK (\le 1000010000). The second line contains KK numbers, separated by a space.

Output Specification:

For each test case, output in one line the largest sum, together with the first and the last numbers of the maximum subsequence. The numbers must be separated by one space, but there must be no extra space at the end of a line. In case that the maximum subsequence is not unique, output the one with the smallest indices ii and jj (as shown by the sample case). If all the KK numbers are negative, then its maximum sum is defined to be 0, and you are supposed to output the first and the last numbers of the whole sequence.

Sample Input:

10
-10 1 2 3 4 -5 -23 3 7 -21

Sample Output:

10 1 4


思路:其实就是最大子列和问题的延伸,同样的套路,只是需要记录下来最大子列的首尾项并输出

但要注意的是,这道题在不同平台上的测试数据不尽相同,尤其当有零项的时候较为让人困惑

例如当序列为0 -1 1 0 1 1 1 -1 时,最大和为3,按照下面的算法,可得首项为0(下标为3),而实际上的首项是1(下标为4)?还是首项为0,(下标为0)?下标从0开始。

这个问题我也不知道该怎么回答,根据pta上的测试用例来看,下面的代码是正确的


代码:

#include<cstdio>
#define maxsize 100010
void Maxsum(int A[],int N)
{
int thissum=0,maxsum=0;
int first=0,last=N;           //定义首尾项的下标
int flag=0;                   //flag来判断是否全为非零项
for(int i=0;i<N;i++)
{
thissum+=A[i];
if(A[i]>=0) flag=1;
if(thissum>maxsum)
{
maxsum=thissum;
last=i;               //先记录末项的下标,并由末项下标来推断首项下标
}
else if(thissum<0)
{
thissum=0;
}
}
int cnt=0;
for(int i=last;i>=0;i--)
{

cnt+=A[i];                           
if(cnt==maxsum)
{
first=i;                  //找到首项  这一步可能有较大的歧义
}

}
if(flag==0) printf("0 %d %d",A[0],A[N-1]);
else
{
if(maxsum==0) printf("0 0 0");
else printf("%d %d %d\n",maxsum,A[first],A[last]);
}


int main()
{
int K;
scanf("%d",&K);
int a[maxsize]={0};
for(int i=0;i<K;i++)
{
scanf("%d",&a[i]);
}
int max;
Maxsum(a,K);
return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
### 内容概要 《计算机试卷1》是一份综合性的计算机基础和应用测试卷,涵盖了计算机硬件、软件、操作系统、网络、多媒体技术等多个领域的知识点。试卷包括单选题和操作应用两大类,单选题部测试学生对计算机基础知识的掌握,操作应用部则评估学生对计算机应用软件的实际操作能力。 ### 适用人群 本试卷适用于: - 计算机专业或信息技术相关专业的学生,用于课程学习或考试复习。 - 准备计算机等级考试或职业资格认证的人士,作为实战演练材料。 - 对计算机操作有兴趣的自学者,用于提升个人计算机应用技能。 - 计算机基础教育工作者,作为教学资源或出题参考。 ### 使用场景及目标 1. **学习评估**:作为学校或教育机构对学生计算机基础知识和应用技能的评估工具。 2. **自学测试**:供个人自学者检验自己对计算机知识的掌握程度和操作熟练度。 3. **职业发展**:帮助职场人士通过实际操作练习,提升计算机应用能力,增强工作竞争力。 4. **教学资源**:教师可以用于课堂教学,作为教学内容的补充或学生的课后练习。 5. **竞赛准备**:适合准备计算机相关竞赛的学生,作为强化训练和技能检测的材料。 试卷的目标是通过系统性的题目设计,帮助学生全面复习和巩固计算机基础知识,同时通过实际操作题目,提高学生解决实际问题的能力。通过本试卷的学习与练习,学生将能够更加深入地理解计算机的工作原理,掌握常用软件的使用方法,为未来的学术或职业生涯打下坚实的基础。

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值