02-线性结构3 Reversing Linked List (25分)

Given a constant KK and a singly linked list LL, you are supposed to reverse the links of every KK elements on LL. For example, given LL being 1→2→3→4→5→6, if K = 3K=3, then you must output 3→2→1→6→5→4; if K = 4K=4, you must output 4→3→2→1→5→6.

Input Specification:

Each input file contains one test case. For each case, the first line contains the address of the first node, a positive NN (\le 10^5105) which is the total number of nodes, and a positive KK (\le NN) which is the length of the sublist to be reversed. The address of a node is a 5-digit nonnegative integer, and NULL is represented by -1.

Then NN lines follow, each describes a node in the format:

Address Data Next

where Address is the position of the node, Data is an integer, and Nextis the position of the next node.

Output Specification:

For each case, output the resulting ordered linked list. Each node occupies a line, and is printed in the same format as in the input.

Sample Input:

00100 6 4
00000 4 99999
00100 1 12309
68237 6 -1
33218 3 00000
99999 5 68237
12309 2 33218

Sample Output:

00000 4 33218
33218 3 12309
12309 2 00100
00100 1 99999
99999 5 68237
68237 6 -1


注意:测试的数据中可能有不在链表上的结点,此结点应直接删除,不予出现,所以数据输入之后,需要建立一个数组,将所有链接起来的结点连在一起,不在链表上的结点直接跳过,之后再进行下一步操作。


#include<cstdio>
#include<algorithm>
using namespace std;
#define maxsize 1000010


struct node                                                     // 定义一个结构体数组
{
int data;
int next;
}node[maxsize];

int List[maxsize];                        
int main()
{
int Adr,Data,Next;
int first,N,K,i;
scanf("%d%d%d",&first,&N,&K);
for( i=0;i<N;i++)                                            //输入数据
{
scanf("%d%d%d",&Adr,&Data,&Next);
node[Adr].data=Data;
node[Adr].next=Next;
}


int p=first;
int j=0;
while(p!=-1)                                                  //将所有在链表上的结点存放在一个数组中,
{
List[j++]=p;
p=node[p].next;
}
i=0;
while(i+K<=j)                                                 // 每k个进行反转并循环
{
reverse(&List[i],&List[i+K]);
i=i+K;
}
for(i=0;i<j-1;i++)
{
printf("%05d %d %05d\n",List[i],node[List[i]].data,List[i+1]);   //  按格式输出
}
printf("%05d %d -1\n",List[i],node[List[i]].data);
return 0;
}


评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值