杭电 hdu2955 0-1背包 Robberies

Robberies

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 17797    Accepted Submission(s): 6574


Problem Description
The aspiring Roy the Robber has seen a lot of American movies, and knows that the bad guys usually gets caught in the end, often because they become too greedy. He has decided to work in the lucrative business of bank robbery only for a short while, before retiring to a comfortable job at a university.


For a few months now, Roy has been assessing the security of various banks and the amount of cash they hold. He wants to make a calculated risk, and grab as much money as possible.


His mother, Ola, has decided upon a tolerable probability of getting caught. She feels that he is safe enough if the banks he robs together give a probability less than this.
 

Input
The first line of input gives T, the number of cases. For each scenario, the first line of input gives a floating point number P, the probability Roy needs to be below, and an integer N, the number of banks he has plans for. Then follow N lines, where line j gives an integer Mj and a floating point number Pj . 
Bank j contains Mj millions, and the probability of getting caught from robbing it is Pj .
 

Output
For each test case, output a line with the maximum number of millions he can expect to get while the probability of getting caught is less than the limit set.

Notes and Constraints
0 < T <= 100
0.0 <= P <= 1.0
0 < N <= 100
0 < Mj <= 100
0.0 <= Pj <= 1.0
A bank goes bankrupt if it is robbed, and you may assume that all probabilities are independent as the police have very low funds.
 

Sample Input
  
  
3 0.04 3 1 0.02 2 0.03 3 0.05 0.06 3 2 0.03 2 0.03 3 0.05 0.10 3 1 0.03 2 0.02 3 0.05
 

Sample Output
  
  
2 4 6
 

Source
 

题目关键是找变量,到底哪个作为价值,哪个作为cost。

这里我们直接上裸0-1背包的代码:

    for(int j=v;j>=a[i].w;j--)//v是容积(拥有的资金,这题目对应警戒值.)
    {
        dp[j]=max(dp[j],dp[j-a[i].w]+a[i].val);
    }
看到了int j=v瞬间整个人就不好了

警戒值特喵的是浮点数。就算是修改为double j=v;j>=a[i].w;j--;这个j--也是直接pass掉了我的想法。。。

这个时候就要寻找变量了。

这里我们可以考虑让银行里边所有钱作为v然后dp数组里边存的是逃跑了的概率。

这个时候我们判断什么是能得到最多的钱的时候就可以这么玩:

        int i;
        for(i=sum;i>=0;i--)
        {
            if(dp[i]>=q)
            break;
        }
        printf("%d\n",i);
这个时候我们定下了思路,然后就是敲代码咯~



#include<stdio.h>
#include<iostream>
#include<string.h>
using namespace std;
struct wupin
{
    int val;float w;
}a[10005];
float dp[10005];
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        memset(dp,0,sizeof(dp));
        float q;int n;
        scanf("%f%d",&q,&n);
        q=1-q;
        int sum=0;
        for(int i=0;i<n;i++)
        {
            scanf("%d%f",&a[i].val,&a[i].w);
            sum+=a[i].val;
            a[i].w=1-a[i].w;
        }
        dp[0]=1;
        for(int i=0;i<n;i++)
        {
            for(int j=sum;j>=a[i].val;j--)
            {
                dp[j]=max(dp[j],dp[j-a[i].val]*a[i].w);
            }
        }
        int i;
        for(i=sum;i>=0;i--)
        {
            if(dp[i]>=q)
            break;
        }
        printf("%d\n",i);
    }
}

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值