DP 入门 HDU-2955

The aspiring Roy the Robber has seen a lot of American movies, and knows that the bad guys usually gets caught in the end, often because they become too greedy. He has decided to work in the lucrative business of bank robbery only for a short while, before retiring to a comfortable job at a university.



For a few months now, Roy has been assessing the security of various banks and the amount of cash they hold. He wants to make a calculated risk, and grab as much money as possible.


His mother, Ola, has decided upon a tolerable probability of getting caught. She feels that he is safe enough if the banks he robs together give a probability less than this.
Input
The first line of input gives T, the number of cases. For each scenario, the first line of input gives a floating point number P, the probability Roy needs to be below, and an integer N, the number of banks he has plans for. Then follow N lines, where line j gives an integer Mj and a floating point number Pj .
Bank j contains Mj millions, and the probability of getting caught from robbing it is Pj .
Output
For each test case, output a line with the maximum number of millions he can expect to get while the probability of getting caught is less than the limit set.

Notes and Constraints
0 < T <= 100
0.0 <= P <= 1.0
0 < N <= 100
0 < Mj <= 100
0.0 <= Pj <= 1.0
A bank goes bankrupt if it is robbed, and you may assume that all probabilities are independent as the police have very low funds.
Sample Input
3
0.04 3
1 0.02
2 0.03
3 0.05
0.06 3
2 0.03
2 0.03
3 0.05
0.10 3
1 0.03
2 0.02
3 0.05
Sample Output
2
4

6

 这道题目是一道DP的基础题,刚刚入门DP,觉得真的太难了,看完大白上的专题来看这个题,发现一点思路都没有,因为概率没法转换到数组下标来处理,而且概率是小数,无法对其进行循环,最后经人提点才想到,先把所有银行的总钱数当做的下标,就是dp[i] 表示的是在能抢i元的时候最安全的概率是多少,经过处理之后,再一轮扫描,找出在安全概率的前提下,最大的i,然后输出就可以了。

还有就是对的dp数组的初始化化很重要。

#include <iostream>
#include <algorithm>
#include <stdio.h>
using namespace std;
#define Max_n 102
int T, N;
double P;
double w[Max_n * Max_n];
double ps[Max_n];
int M[Max_n];
int sum;
void intit()
{
  sum = 0;
  for (int i = 0; i < N; i++)
    sum += M[i];   //用sum来记录最大的钱数。
  w[0] = 1;
  for (int i = 1; i <= sum; i++)  //这步初始化很重要,因外抢0元钱是一定安全的,而其余情况下都要初始化话成最不安全的。
    w[i] = 0;
}
int main ()
{
  scanf("%d", &T);
  while (T--) {
    scanf("%lf%d", &P, &N);
    for (int i = 0; i < N; i++)
      scanf("%d%lf", &M[i], &ps[i]);
    intit ();
    for (int i = 0; i < N; i++)   // 在有i个银行的前提下,对于抢j元钱的最大安全率。
      for (int j = sum; j >= M[i]; j --)
        w[j] = max(w[j], w[j-M[i]] * (1 - ps[i]));
    for (int j = sum;j >= 0; j--) {
      if (w[j] > (1 - P)) {
        printf ("%d\n", j);
        break;
      }
    }
  }
  return 0;
}


  • 2
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值