杭电 hdu 5280 Senior's Array(dp)

Senior's Array

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 1605    Accepted Submission(s): 542


Problem Description
One day, Xuejiejie gets an array A . Among all non-empty intervals of A , she wants to find the most beautiful one. She defines the beauty as the sum of the interval. The beauty of the interval--- [L,R] is calculated by this formula : beauty(L,R) = A[L]+A[L+1]+......+A[R] . The most beautiful interval is the one with maximum beauty.

But as is known to all, Xuejiejie is used to pursuing perfection. She wants to get a more beautiful interval. So she asks Mini-Sun for help. Mini-Sun is a magician, but he is busy reviewing calculus. So he tells Xuejiejie that he can just help her change one value of the element of A to P . Xuejiejie plans to come to see him in tomorrow morning.

Unluckily, Xuejiejie oversleeps. Now up to you to help her make the decision which one should be changed(You must change one element).
 


Input
In the first line there is an integer T , indicates the number of test cases.

In each case, the first line contains two integers n and P . n means the number of elements of the array. P means the value Mini-Sun can change to.

The next line contains the original array.

1n1000 , 109A[i],P109
 


Output
For each test case, output one integer which means the most beautiful interval's beauty after your change.
 


Sample Input
  
  
2 3 5 1 -1 2 3 -2 1 -1 2
 


Sample Output
  
  
8 2


修改一个数组内元素的值,使得子序列的和最大,这里数据范围比较小,只有1000,我们用一个for来改变元素的值,然后再用一个for来dp求最大子序列的和,

我们这里的复杂度为n^2,1000*1000是最大的操作次数,是不会超时的,所以我们这里暴力DP解决。但是这里有个小小的坑:注意这里元素数据范围比较大,用int会WA,我们这里要用long long。
直接上AC代码:

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
#define ll long long int
ll a[1005];
ll dp[1005];
int main()
{
    ll t;
    scanf("%lld",&t);
    while(t--)
    {
        ll n,p;
        ll output=-0x1f1f1f1f;
        scanf("%lld%lld",&n,&p);
        for(ll i=1;i<=n;i++)
        {
            scanf("%lld",&a[i]);
        }
        memset(dp,0,sizeof(dp));
        for(ll i=1;i<=n;i++)
        {
            int  tmp=a[i];
            a[i]=p;
            for(ll j=1;j<=n;j++)//dp核心。
            {
                dp[j]=max(a[j],dp[j-1]+a[j]);
                output=max(output,dp[j]);
            }
            a[i]=tmp;
        }
        printf("%lld\n",output);
    }
}








评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值