hdu 5170 GTY's math problem【精度控制】【思维】

GTY's math problem

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 1872    Accepted Submission(s): 706


Problem Description
GTY is a GodBull who will get an Au in NOI . To have more time to learn algorithm knowledge, he never does his math homework. His math teacher is very unhappy for that, but she can't do anything because GTY can always get a good mark in math exams. One day, the math teacher asked GTY to answer a question. There are four numbers on the blackboard - a,b,c,d . The math teacher wants GTY to compare ab with cd . Because GTY never does his homework, he can't figure out this problem! If GTY can't answer this question correctly, he will have to do his homework. So help him!
 


Input
Multi test cases (about 5000). Every case contains four integers a,b,c,d( 1a,b,c,d1000 )separated by spaces. Please process to the end of file.
 


Output
For each case , if ab>cd , print '>'. if ab<cd , print '<'. if ab=cd , print '='.
 


Sample Input
  
  
2 1 1 2 2 4 4 2 10 10 9 11
 


Sample Output
  
  
> = <

数据两边求log,再进行数据比较,难点在于精度控制:

#include<stdio.h>
#include<string.h>
#include<math.h>
#include<iostream>
using namespace std;
int main()
{
    double a,b,c,d;
    while(cin>>a>>b>>c>>d)
    {
        double e=b*log(a);
        double f=d*log(c);
        if(e-f>1e-10)cout<<">"<<endl;
        else if(f-e>1e-10)cout<<"<"<<endl;
        else cout<<"="<<endl;
    }
}





  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值