hdu 5479 Scaena Felix【栈应用】【括号匹配】

Scaena Felix

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 730    Accepted Submission(s): 303


Problem Description
Given a parentheses sequence consist of '(' and ')', a modify can filp a parentheses, changing '(' to ')' or ')' to '('.

If we want every not empty <b>substring</b> of this parentheses sequence not to be "paren-matching", how many times at least to modify this parentheses sequence?

For example, "()","(())","()()" are "paren-matching" strings, but "((", ")(", "((()" are not.
 

Input
The first line of the input is a integer  T , meaning that there are  T  test cases.

Every test cases contains a parentheses sequence  S  only consists of '(' and ')'.

1|S|1,000 .
 

Output
For every test case output the least number of modification.
 

Sample Input
  
  
3 () (((( (())
 

Sample Output
  
  
1 0 2
 
问题描述
给定一个由'('和')'组成的字符串,一次修改可以翻转字符串中的一个字符,将'('变成')'或者将')'变成'('。
如果要让这个字符串中任意一个非空子串都不是括号匹配串,至少要修改多少次?
比如"()","(())","()()" 是括号匹配串, 但"((", ")(", "((()" 不是。
输出描述
对每组数据输出至少需要修改的字符数。
一道很水的题、问如何最少修改字符数变成任何括号都不匹配的字符串,相反的,如果我们找到了多少匹配的括号,就相当于知道了要处理多少括号,所以这个题目,就相当于问你,有多少个括号是匹配的,最简单的栈应用~

#include<stdio.h>
#include<string.h>
#include<stack>
using namespace std;
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        stack<char>s;
        int output=0;
        char a[10000];
        scanf("%s",a);
        for(int i=0;i<strlen(a);i++)
        {
            if(a[i]=='(')
            {
                s.push(a[i]);
            }
            if(a[i]==')')
            {
                if(s.size()!=0)
                {
                    s.pop();
                    output++;
                }
            }
        }
        printf("%d\n",output);
    }
}





  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值