POJ 2560

Freckles
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 8055 Accepted: 3862

Description

In an episode of the Dick Van Dyke show, little Richie connects the freckles on his Dad's back to form a picture of the Liberty Bell. Alas, one of the freckles turns out to be a scar, so his Ripley's engagement falls through. 
Consider Dick's back to be a plane with freckles at various (x,y) locations. Your job is to tell Richie how to connect the dots so as to minimize the amount of ink used. Richie connects the dots by drawing straight lines between pairs, possibly lifting the pen between lines. When Richie is done there must be a sequence of connected lines from any freckle to any other freckle.

Input

The first line contains 0 < n <= 100, the number of freckles on Dick's back. For each freckle, a line follows; each following line contains two real numbers indicating the (x,y) coordinates of the freckle.

Output

Your program prints a single real number to two decimal places: the minimum total length of ink lines that can connect all the freckles.

Sample Input

3
1.0 1.0
2.0 2.0
2.0 4.0

Sample Output

3.41

Source


题目大意:给你n个点,让你把他们全部链接起来,使得用的笔油最少(就这么理解就可以了~不要吐槽~~)

很典型的最小生成树的题目,我们这里把所有的点距离求出来,然后对点也标记上序号、这里注意精度控制问题,double会损失精度,我们要用float变量类型才行,这里直接上代码:

#include<stdio.h>
#include<string.h>
#include<math.h>
#include<algorithm>
using namespace std;
struct path
{
    int x,y;
    float val;
}a[1000000];
int f[1000000];
float x[1000];
float y[1000];
int cmp(path a,path b)
{
    return a.val<b.val;
}
int find(int x)
{
    return f[x] == x ? x : (f[x] = find(f[x]));
}
void merge(int a,int b)
{
    int A,B;
    A=find(a);
    B=find(b);
    if(A!=B)
    f[B]=A;
}
int main()
{
    int n;
    int cont=0;
    scanf("%d",&n);
    for(int i=0;i<1000000;i++)
    {
        f[i]=i;
    }
    for(int i=0;i<n;i++)
    {
        scanf("%f%f",&x[i],&y[i]);
        for(int j=0;j<i;j++)
        {
            a[cont].x=i;
            a[cont].y=j;
            a[cont].val=sqrt((x[i]-x[j])*(x[i]-x[j])+(y[i]-y[j])*(y[i]-y[j]));
            cont++;
        }
    }
    float output=0;
    sort(a,a+cont,cmp);
    for(int i=0;i<cont;i++)
    {
        if(find(a[i].x)!=find(a[i].y))
        {
            merge(a[i].x,a[i].y);
            output+=a[i].val;
        }
    }
    printf("%.2f",output);
}








评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值