hdu 1532 Drainage Ditches【最大流】

Drainage Ditches

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 13890    Accepted Submission(s): 6574


Problem Description
Every time it rains on Farmer John's fields, a pond forms over Bessie's favorite clover patch. This means that the clover is covered by water for awhile and takes quite a long time to regrow. Thus, Farmer John has built a set of drainage ditches so that Bessie's clover patch is never covered in water. Instead, the water is drained to a nearby stream. Being an ace engineer, Farmer John has also installed regulators at the beginning of each ditch, so he can control at what rate water flows into that ditch. 
Farmer John knows not only how many gallons of water each ditch can transport per minute but also the exact layout of the ditches, which feed out of the pond and into each other and stream in a potentially complex network. 
Given all this information, determine the maximum rate at which water can be transported out of the pond and into the stream. For any given ditch, water flows in only one direction, but there might be a way that water can flow in a circle. 
 

Input
The input includes several cases. For each case, the first line contains two space-separated integers, N (0 <= N <= 200) and M (2 <= M <= 200). N is the number of ditches that Farmer John has dug. M is the number of intersections points for those ditches. Intersection 1 is the pond. Intersection point M is the stream. Each of the following N lines contains three integers, Si, Ei, and Ci. Si and Ei (1 <= Si, Ei <= M) designate the intersections between which this ditch flows. Water will flow through this ditch from Si to Ei. Ci (0 <= Ci <= 10,000,000) is the maximum rate at which water will flow through the ditch.
 

Output
For each case, output a single integer, the maximum rate at which water may emptied from the pond. 
Sample Input
5 4
1 2 40
1 4 20
2 4 20
2 3 30
3 4 10
 


Sample Output
50
 
 


Source
 

题目大意:下雨约翰家会被大雨袭击,因为他要解决问题所以建立了一个排水系统。约翰很聪明,能够控制每一条沟的水流量,问最大水流量。

思路:裸的最大流问题。

AC代码:

#include <stdio.h>
#include <iostream>
#include <string.h>
#include <queue>
using namespace std;
const int N=1005;
int pre[N];       //保存增广路径上的点的前驱顶点
bool vis[N];
int map[N][N];
int s,t;          //s为源点,t为汇点
int n,m;
bool bfs()
{
    int i,cur;
    queue<int >q;
    memset(pre,0,sizeof(pre));
    memset(vis,0,sizeof(vis));
    vis[s]=true;
    q.push(s);
    while(!q.empty())
    {
        cur=q.front();
        q.pop();
        if(cur==t)return true;
        for(int i=1;i<=n;i++)
        {
            if(vis[i]==0&&map[cur][i])
            {
                q.push(i);
                pre[i]=cur;
                vis[i]=true;
            }
        }
    }
    return false;
}
int Max_Flow()
{
    int ans=0;
    while(1)
    {
        if(!bfs())return ans;
        int Min=0x3f3f3f3f;
        for(int i=t;i!=s;i=pre[i])
        {
            Min=min(Min,map[pre[i]][i]);
        }
        for(int i=t;i!=s;i=pre[i])
        {
            map[pre[i]][i]-=Min;
            map[i][pre[i]]+=Min;
        }
        ans+=Min;
    }
}
int main()
{
    int T,k=1;
    int u,v,c;
    while(~scanf("%d%d",&m,&n))
    {
        s=1;
        t=n;
        memset(map,0,sizeof(map));
        for(int i=0;i<m;i++)
        {
            scanf("%d%d%d",&u,&v,&c);
            map[u][v]+=c;
        }
        printf("%d\n",Max_Flow());
    }
}












  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值