hdu 3284 Adjacent Bit Counts【dp】

Adjacent Bit Counts

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 390    Accepted Submission(s): 320


Problem Description
For a string of n bits x 1, x 2, x 3, …, x n, the adjacent bit count of the string ( AdjBC(x)) is given by

x1*x2 + x2*x3 + x3*x4 + … + xn-1*xn

which counts the number of times a 1 bit is adjacent to another 1 bit. For example:

AdjBC(011101101) = 3
AdjBC(111101101) = 4
AdjBC(010101010) = 0

Write a program which takes as input integers n and k and returns the number of bit strings x of n bits (out of 2 n) that satisfy AdjBC(x) = k. For example, for 5 bit strings, there are 6 ways of getting
AdjBC(x) = 2:

11100, 01110, 00111, 10111, 11101, 11011
 

Input
The first line of input contains a single integer P, (1 ≤ P ≤ 1000), which is the number of data sets that follow. Each data set is a single line that contains the data set number, followed by a space, followed by a decimal integer giving the number (n) of bits in the bit strings, followed by a single space, followed by a decimal integer (k) giving the desired adjacent bit count. The number of bits (n) will not be greater than 100 and the parameters n and k will be chosen so that the result will fit in a signed 32-bit integer.
 

Output
For each data set there is one line of output. It contains the data set number followed by a single space, followed by the number of n-bit strings with adjacent bit count equal to k.

 Sample Input
10
1 5 2
2 20 8
3 30 17
4 40 24
5 50 37
6 60 52
7 70 59
8 80 73
9 90 84
10 100 90
 


Sample Output
1 6
2 63426
3 1861225
4 168212501
5 44874764
6 160916
7 22937308
8 99167
9 15476
10 23076518

 

题目大意:输入num,n,k。输出 num,方案数。方案数表示长度为n的串权值恰好为k的所有方案数。

思路:

简单dp求解。

我们设dp【i】【j】【k】表示长度为i最后一个字母为j的权值为k的串的方案数。

那么不难推出:

dp【i】【0】【k】=dp【i-1】【0】【k】+dp【i-1】【1】【k】;//最后一个字母如果为0的话,那么方案数应该来自于长度i-1的最后一个字母任意的方案数加和

dp【i】【1】【k】=dp【i-1】【0】【k】+dp【i-1】【1】【k-1】;//最后一个字母如果为1的话,那么方案数应该来自于长度为i-1最后一个字母为0的方案数和长度为i-1最后一个字母为1的权值为k-1的方案数的加和。

注意处理权值为0的时候的方案数。

AC代码:

#include<stdio.h>
#include<string.h>
using namespace std;
int  dp[105][2][105];//i j quanzhi k
int main()
{
    memset(dp,0,sizeof(dp));
    dp[1][1][0]=dp[1][0][0]=1;
    for(int i=2;i<=105;i++)
    {
        dp[i][0][0]=dp[i-1][0][0]+dp[i-1][1][0];
        dp[i][1][0]=dp[i-1][0][0];
        for(int j=1;j<i;j++)
        {
            dp[i][0][j]=dp[i-1][0][j]+dp[i-1][1][j];
            dp[i][1][j]=dp[i-1][1][j-1]+dp[i-1][0][j];
        }
    }
    int t;
    scanf("%d",&t);
    while(t--)
    {
        int num,n,k;
        scanf("%d%d%d",&num,&n,&k);
        printf("%d %d\n",num,dp[n][0][k]+dp[n][1][k]);
    }
}













  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值