Problem Description
For a string of n bits x1, x2, x3, …, xn, the adjacent bit count of the string (AdjBC(x)) is given by
x1x2 + x2x3 + x3x4 + … + xn-1xn
which counts the number of times a 1 bit is adjacent to another 1 bit. For example:
AdjBC(011101101) = 3
AdjBC(111101101) = 4
AdjBC(010101010) = 0
Write a program which takes as input integers n and k and returns the number of bit strings x of n bits (out of 2n) that satisfy AdjBC(x) = k. For example, for 5 bit strings, there are 6 ways of getting
AdjBC(x) = 2:
11100, 01110, 00111, 10111, 11101, 11011
Input
The first line of input contains a single integer P, (1 ≤ P ≤ 1000), which is the number of data sets that follow. Each data set is a single line that contains the data set number, followed by a space, followed by a decimal integer giving the number (n) of bits in the bit strings, followed by a single space, followed by a decimal integer (k) giving the desired adjacent bit count. The number of bits (n) will not be greater than 100 and the parameters n and k will be chosen so that the result will fit in a signed 32-bit integer.
Output
For each data set there is one line of output. It contains the data set number followed by a single space, followed by the number of n-bit strings with adjacent bit count equal to k.
Sample Input
10
1 5 2
2 20 8
3 30 17
4 40 24
5 50 37
6 60 52
7 70 59
8 80 73
9 90 84
10 100 90
Sample Output
1 6
2 63426
3 1861225
4 168212501
5 44874764
6 160916
7 22937308
8 99167
9 15476
10 23076518
题意:
01串的权值为x1x2 + x2x3 + x3x4 + … + xn-1xn
给n和k,求长度为n,权值为k的01串有多少种
思路:
d[i][j][k]表示长度为i,权值为j,结尾为k的方案数(k为0或1)
预处理0的情况:
d[i][0][0]=d[i-1][0][0]+d[i-1][0][1];
d[i][0][1]=d[i-1][0][0];
一般情况:
d[i][j][0]+=d[i-1][j][0]+d[i-1][j][1];
d[i][j][1]+=d[i-1][j][0]+d[i-1][j-1][1];
code:
#include<bits/stdc++.h>
using namespace std;
const int maxm=105;
int d[maxm][maxm][2];//d[i][j][k],表示长度为i,权值为j,结尾为k的方案数
void init(){
d[1][0][0]=d[1][0][1]=1;
for(int i=2;i<maxm;i++){//枚举长度
d[i][0][0]=d[i-1][0][0]+d[i-1][0][1];
d[i][0][1]=d[i-1][0][0];
for(int j=1;j<i;j++){//枚举权值,最大枚举到i-1
d[i][j][0]+=d[i-1][j][0]+d[i-1][j][1];
d[i][j][1]+=d[i-1][j][0]+d[i-1][j-1][1];
}
}
}
signed main(){
init();
int T;
cin>>T;
while(T--){
int cas;
cin>>cas;
int n,k;
cin>>n>>k;
cout<<cas<<' '<<d[n][k][0]+d[n][k][1]<<endl;
}
return 0;
}