hdu 5660 jrMz and angles【暴力枚举】【水题】

jrMz and angles

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 183    Accepted Submission(s): 124


Problem Description
jrMz has two types of angles, one type of angle is an interior angle of  n -sided regular polygon, and the other type of angle is an interior angle of  m -sided regular polygon. jrMz wants to use them to make up an angle of 360 degrees, which means, jrMz needs to choose some or none of the angles which belong to the first type and some or none of the angles which belong to the second type so that the sum value of the angles chosen equals 360 degrees. But jrMz doesn’t know whether it is possible, can you help him?
 

Input
The first line contains an integer  T(1T10) ——The number of the test cases.
For each test case, the only line contains two integers  n,m(1n,m100)  with a white space separated.
 

Output
For each test case, the only line contains a integer that is the answer.
 Sample Input
3
4 8
3 10
5 8
 


Sample Output
Yes
Yes
No

题目大意:给你一个正n边型,一个正m边型,问你能否从两个正边行中找出能够组成360度的角,如果可以,输出Yes,否则No。

思路:
暴力枚举。

AC代码:

#include<stdio.h>
#include<string.h>
using namespace std;
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        int n,m;
        scanf("%d%d",&n,&m);
        int neijiaohe=(n-2)*180;
        int neijiaohe2=(m-2)*180;
        int a=neijiaohe/n;
        int b=neijiaohe2/m;
        int ok=0;
        for(int i=0;;i++)
        {
            if(i*a>360)break;
            for(int j=0;;j++)
            {
                if(j*b+i*a>360)break;
                if(a*i+b*j==360)
                {
                    ok=1;
                    break;
                }
            }
            if(ok==1)break;
        }
        if(ok==1)printf("Yes\n");
        else printf("No\n");
    }
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值