hrbust/哈理工oj 2116 Maximum continuous product【水题】

Maximum continuous product
Time Limit: 1000 MS Memory Limit: 32768 K
Total Submit: 107(37 users) Total Accepted: 33(29 users) Rating: Special Judge: No
Description
Wind and his GF(game friend) are playing a small game. They use the computer to randomly generated a number sequence which only include number 2,0 and -2. To be the winner,wind must 


have to find a continuous subsequence whose continuous product is maximum.


For example, we have a sequence blow:


2 2 0 -2 0 2 2 -2 -2 0


Among all of it's continuous subsequences, 2 2 -2 -2 own the maximum continuous product.


(2*2*(-2)*(-2) = 16 ,and 16 is the maximum continuous product)


You,wind's friend,can give him a hand.




Input
The first line is an integer T which is the Case number(T <= 200).


For each test case, there is an integer N indicating the length of the number sequence.(1<= N <= 10000)


The next line,there are N integers which only include 2,0 and -2.




Output
For each case,you have to output the case number first(Reference the sample).


If the answer is smaller than 0, you just need to output 0 as the answer.


If the answer's format is 2^x,you need to output the x as the answer.


Output the answer in one line.




Sample Input
2
2
-2 0
10
2 2 0 -2 0 2 2 -2 -2 0
Sample Output
Case #1: 0
Case #2: 4
Source
ACM-ICPC黑龙江省第九届大学生程序设计竞赛选拔赛(2)

竟然直接暴力就能过T___T害我wa了好久T-T

AC代码:

#include<stdio.h>
#include<string.h>
using namespace std;
int a[100000];
int main()
{
    int t;
    int kase=0;
    scanf("%d",&t);
    while(t--)
    {
        int n;
        scanf("%d",&n);
        for(int i=0;i<n;i++)
        {
            scanf("%d",&a[i]);
        }
        int output=0;
        int cnt=0;
        int flag=0;
        for(int i=0;i<n;i++)
        {
            if(a[i]==0)continue;
            cnt=0;
            flag=0;
            for(int j=i;j<n;j++)
            {
                if(a[j]==0)break;
                if(a[j]==2)cnt++;
                if(a[j]==-2){flag=1-flag;cnt++;}
                if(flag==0&&cnt>output){output=cnt;}
            }
        }
        printf("Case #%d: %d\n",++kase,output);
    }
}
/*
100
4
-2 2 2 2
4
-2 2 0 2
4
2 -2 2 0
8
2 -2 2 0 2 -2 2 2
10
2 -2 -2 2 2 2 -2 2 0 -2
10
0 2 2 -2 2 0 -2 0 0 0
8
2 0 2 -2 2 2 -2 2
*/















  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值