hdu 1164 Eddy's research I【快速打印素数表】【水题】

Eddy's research I

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 8532    Accepted Submission(s): 5243

Problem Description

Eddy's interest is very extensive, recently he is interested in prime number. Eddy discover the all number owned can be divided into the multiply of prime number, but he can't write program, so Eddy has to ask intelligent you to help him, he asks you to write a program which can do the number to divided into the multiply of prime number factor .

 

 

Input

The input will contain a number 1 < x<= 65535 per line representing the number of elements of the set.

 

 

Output

You have to print a line in the output for each entry with the answer to the previous question.

 

 

Sample Input

11

9412

 

 

Sample Output

11

2*2*13*181

 

 

Author

eddy

 

思路:把素数打出来,然后存入一个数组中,循环处理n即可。

AC代码:

#include<stdio.h>
#include<string.h>
#include<math.h>
using namespace std;
#define maxn 65550
int Is_or[maxn];
int su[maxn];
int cont;
void init()
{
        memset(Is_or,0,sizeof(Is_or));
    for(int j=2;j<sqrt(maxn);j++)//
    {
        if(Is_or[j]==0)//去掉合数的倍数.
        for(int k=j+j;k<=maxn;k+=j)//去掉倍数.(把这么些个合数的倍数都标记上这个数不是素数.)
        Is_or[k]=1;
    }
    for(int i=2;i<=maxn;i++)
    {
        if(Is_or[i]==0)
        {
            su[cont++]=i;
        }
    }
}
int main()
{
    cont=0;
    init();
    int n;
    while(~scanf("%d",&n))
    {
        int f=0;
        while(1)
        {
            if(n==1)break;
            for(int i=0;i<cont;i++)
            {
                if(n%su[i]==0)
                {
                    n/=su[i];
                    if(f==0)
                    printf("%d",su[i]),f++;
                    else printf("*%d",su[i]);
                    break;
                }
            }
            if(n==1)break;
        }
        printf("\n");
    }
}













  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值