HDU 1164 Eddy's research I(素数打表)

Eddy's interest is very extensive, recently he is interested in prime number. Eddy discover the all number owned can be divided into the multiply of prime number, but he can't write program, so Eddy has to ask intelligent you to help him, he asks you to write a program which can do the number to divided into the multiply of prime number factor .

Input
The input will contain a number 1 < x<= 65535 per line representing the number of elements of the set.
Output
You have to print a line in the output for each entry with the answer to the previous question.
Sample Input
11
9412
Sample Output
11
2213*181

题意:

任何一个数都能拆分成质因子相乘。

题解:

把范围内的所有素数筛选出来,然后找就行了。

#include<iostream>
#include<cstdio>
#include<algorithm>
using namespace std;
const int maxn=1e5+5;
int prime[maxn];
int is_prime[maxn];
int sieve(int n)
{
    int cnt=0;
    for(int i=0;i<=n;i++)
        is_prime[i]=true;
    is_prime[0]=is_prime[1]=false;
    for(int i=2;i<=n;i++)
    {
        if(is_prime[i])
        {
            prime[cnt++]=i;
            for(int j=2*i;j<=n;j+=i)
                is_prime[j]=false;
        }
    }
    return cnt;
}
int main()
{
    int k=sieve(65535);
    int n;
    while(cin>>n)
    {
        bool flag=true;
        for(int i=0;i<k;i++)
        {
            while(n&&n%prime[i]==0)
            {
                n/=prime[i];
                if(flag)
                {
                    flag=false;
                    cout<<prime[i];
                }
                else
                    cout<<'*'<<prime[i];
            }
            if(!n)
                break;
        }
        cout<<endl;
    }
    return 0;
}

转载于:https://www.cnblogs.com/orion7/p/7930979.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值