hdu 2822 Dogs【优先队列+Bfs】

Dogs

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2547    Accepted Submission(s): 983

Problem Description

Prairie dog comes again! Someday one little prairie dog Tim wants to visit one of his friends on the farmland, but he is as lazy as his friend (who required Tim to come to his place instead of going to Tim's), So he turn to you for help to point out how could him dig as less as he could.

We know the farmland is divided into a grid, and some of the lattices form houses, where many little dogs live in. If the lattices connect to each other in any case, they belong to the same house. Then the little Tim start from his home located at (x0, y0) aim at his friend's home ( x1, y1 ). During the journey, he must walk through a lot of lattices, when in a house he can just walk through without digging, but he must dig some distance to reach another house. The farmland will be as big as 1000 * 1000, and the up left corner is labeled as ( 1, 1 ).

 

 

Input

The input is divided into blocks. The first line in each block contains two integers: the length m of the farmland, the width n of the farmland (m, n ≤ 1000). The next lines contain m rows and each row have n letters, with 'X' stands for the lattices of house, and '.' stands for the empty land. The following two lines is the start and end places' coordinates, we guarantee that they are located at 'X'. There will be a blank line between every test case. The block where both two numbers in the first line are equal to zero denotes the end of the input.

 

 

Output

For each case you should just output a line which contains only one integer, which is the number of minimal lattices Tim must dig.

 

 

Sample Input

6 6

..X...

XXX.X.

....X.

X.....

X.....

X.X...

3 5

6 3

 

0 0

 

 

Sample Output

3

 

Hint

 

Hint: Three lattices Tim should dig: ( 2, 4 ), ( 3, 1 ), ( 6, 2 ).

 

 

 

Source

2009 Multi-University Training Contest 1 - Host by TJU

 

题目大意:#是能够直接走的格子,“.”是不能直接走需要dig的格子,问最少需要dig多少格子就能到达目的地。


思路:优先队列控制 dig数最小值优先,Bfs即可。


AC代码:

#include<stdio.h>
#include<string.h>
#include<queue>
using namespace std;
struct zuobiao
{
    int x,y,output;
    friend bool operator <(zuobiao a,zuobiao b)
    {
        return a.output>b.output;
    }
}now,nex;
int n,m;
int sx,sy,ex,ey;
char a[1010][1010];
int vis[1010][1010];
int fx[4]={0,0,1,-1};
int fy[4]={1,-1,0,0};
void Bfs(int x,int y)
{
    priority_queue<zuobiao>s;
    memset(vis,0,sizeof(vis));
    now.x=x;
    now.y=y;
    now.output=0;
    vis[now.x][now.y]=1;
    s.push(now);
    while(!s.empty())
    {
        now=s.top();
        if(now.x==ex&&now.y==ey)
        {
            printf("%d\n",now.output);
            return ;
        }
        s.pop();
        for(int i=0;i<4;i++)
        {
            nex.x=now.x+fx[i];
            nex.y=now.y+fy[i];
            nex.output=now.output;
            if(nex.x>=0&&nex.x<n&&nex.y>=0&&nex.y<m&&vis[nex.x][nex.y]==0)
            {
                vis[nex.x][nex.y]=1;
                if(a[nex.x][nex.y]=='.')nex.output++;
                s.push(nex);
            }
        }
    }
}
int main()
{
    while(~scanf("%d%d",&n,&m))
    {
        if(n+m==0)break;
        for(int i=0;i<n;i++)
        {
            scanf("%s",&a[i]);
        }
        scanf("%d%d%d%d",&sx,&sy,&ex,&ey);
        sx--;sy--;ex--;ey--;
        Bfs(sx,sy);
    }
}












  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值