hdu 3592 World Exhibition 【差分约束+SPFA】

World Exhibition

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1523    Accepted Submission(s): 759

Problem Description

Nowadays, many people want to go to Shanghai to visit the World Exhibition. So there are always a lot of people who are standing along a straight line waiting for entering. Assume that there are N (2 <= N <= 1,000) people numbered 1..N who are standing in the same order as they are numbered. It is possible that two or more person line up at exactly the same location in the condition that those visit it in a group.

There is something interesting. Some like each other and want to be within a certain distance of each other in line. Some really dislike each other and want to be separated by at least a certain distance. A list of X (1 <= X <= 10,000) constraints describes which person like each other and the maximum distance by which they may be separated; a subsequent list of Y constraints (1 <= Y <= 10,000) tells which person dislike each other and the minimum distance by which they must be separated.

Your job is to compute, if possible, the maximum possible distance between person 1 and person N that satisfies the distance constraints.

Input

First line: An integer T represents the case of test.

The next line: Three space-separated integers: N, X, and Y. 

The next X lines: Each line contains three space-separated positive integers: A, B, and C, with 1 <= A < B <= N. Person A and B must be at most C (1 <= C <= 1,000,000) apart.

The next Y lines: Each line contains three space-separated positive integers: A, B, and C, with 1 <= A < B <= C. Person A and B must be at least C (1 <= C <= 1,000,000) apart.

Output

For each line: A single integer. If no line-up is possible, output -1. If person 1 and N can be arbitrarily far apart, output -2. Otherwise output the greatest possible distance between person 1 and N.

 

Sample Input

1

4 2 1

1 3 8

2 4 15

2 3 4

Sample Output

19

Author

alpc20

 

 题目大意:很多人都想去上海看世博会,然而很多地方都要排队等候,设有长度为n的一个队列,其中有很多复杂的人际关系,X个相对关系较好的关系,Y个相对关系不好的关系,关系好的人想尽量挨着,关系不好的人想尽量远离。输入中第一行给出t组数据,N,X,Y表示n个长度的队列,X,Y个关系,下列X行,输入a,b,c表示a和b的距离不要大于c,下列Y行,输入a,b,c表示a和b的距离不要小于c。求1号和n号人最大的距离。



思路:很明显的差分约束系统的题目,我们转化方程式为ta-tb<=k的形式我们就可以将整个问题转化到最短路径问题上来。

如果对差分约束系统的不等式转化到最短路径问题不太理解的小伙伴可以先看看这个题和题解,我详细描述了一下如何转换的问题:http://blog.csdn.net/mengxiang000000/article/details/51544512


X:a-b<=c

Y:a-b>=c

转化到:

X:a-b<=c

Y:b-a<=-c


那么不难看出,c一定是正的,那么-c就一定是负的,所以Dij是行不通的,我萌来使用SPFA算法最终解出其中的解。


注意的点:如果存在负权回路输出-1,如果没法计算从1到n的最大距离,那么输出-2


AC代码:

#include<stdio.h>
#include<string.h>
#include<queue>
using namespace std;
int head[100000];
struct EdgeNode
{
    int to;
    int w;
    int next;
}e[100000];
int out[100000];
int vis[100000];
int dis[100000];
int cont,n,x,y;
void add(int u,int v,int w)
{
    e[cont].to=v;
    e[cont].w=w;
    e[cont].next=head[u];
    head[u]=cont++;
}
int SPFA()
{
    queue<int >s;
    memset(vis,0,sizeof(vis));
    for(int i=1;i<=n;i++)dis[i]=0x3f3f3f3f;
    dis[1]=0;
    vis[1]=1;
    s.push(1);
    while(!s.empty())
    {
        int u=s.front();
        out[u]++;
        if(out[u]>n)return 0;
        s.pop();
        vis[u]=0;
        for(int k=head[u];k!=-1;k=e[k].next)
        {
            int v=e[k].to;int w=e[k].w;
            if(dis[v]>dis[u]+w)
            {
                dis[v]=dis[u]+w;
                if(vis[v]==0)
                {
                    vis[v]=1;
                    s.push(v);
                }
            }
        }
    }
    if(dis[n]!=0x3f3f3f3f)
    printf("%d\n",dis[n]);
    else printf("-2\n");
    return 1;
}
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        cont=0;
        memset(out,0,sizeof(out));
        memset(head,-1,sizeof(head));
        scanf("%d%d%d",&n,&x,&y);
        for(int i=0;i<x;i++)
        {
            int u,v,w;
            scanf("%d%d%d",&u,&v,&w);
            add(u,v,w);
        }
        for(int i=0;i<y;i++)
        {
            int u,v,w;
            scanf("%d%d%d",&u,&v,&w);
            add(v,u,-w);
        }
        int t=SPFA();
        if(t==0)
        {
            printf("-1\n");
        }
    }
}





  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值