Poj 1860 Currency Exchange【SPFA】

Currency Exchange

Time Limit: 1000MS

 

Memory Limit: 30000K

Total Submissions: 25596

 

Accepted: 9379

Description

Several currency exchange points are working in our city. Let us suppose that each point specializes in two particular currencies and performs exchange operations only with these currencies. There can be several points specializing in the same pair of currencies. Each point has its own exchange rates, exchange rate of A to B is the quantity of B you get for 1A. Also each exchange point has some commission, the sum you have to pay for your exchange operation. Commission is always collected in source currency. 
For example, if you want to exchange 100 US Dollars into Russian Rubles at the exchange point, where the exchange rate is 29.75, and the commission is 0.39 you will get (100 - 0.39) * 29.75 = 2963.3975RUR. 
You surely know that there are N different currencies you can deal with in our city. Let us assign unique integer number from 1 to N to each currency. Then each exchange point can be described with 6 numbers: integer A and B - numbers of currencies it exchanges, and real RAB, CAB, RBA and CBA - exchange rates and commissions when exchanging A to B and B to A respectively. 
Nick has some money in currency S and wonders if he can somehow, after some exchange operations, increase his capital. Of course, he wants to have his money in currency S in the end. Help him to answer this difficult question. Nick must always have non-negative sum of money while making his operations. 

Input

The first line of the input contains four numbers: N - the number of currencies, M - the number of exchange points, S - the number of currency Nick has and V - the quantity of currency units he has. The following M lines contain 6 numbers each - the description of the corresponding exchange point - in specified above order. Numbers are separated by one or more spaces. 1<=S<=N<=100, 1<=M<=100, V is real number, 0<=V<=103
For each point exchange rates and commissions are real, given with at most two digits after the decimal point, 10-2<=rate<=102, 0<=commission<=102
Let us call some sequence of the exchange operations simple if no exchange point is used more than once in this sequence. You may assume that ratio of the numeric values of the sums at the end and at the beginning of any simple sequence of the exchange operations will be less than 104

Output

If Nick can increase his wealth, output YES, in other case output NO to the output file.

Sample Input

3 2 1 20.0

1 2 1.00 1.00 1.00 1.00

2 3 1.10 1.00 1.10 1.00

Sample Output

YES

Source

Northeastern Europe 2001, Northern Subregion

 

题目大意:有n个点,m条边,初始源点和初始金钱。

有m条边,表示1号货币换2号货币的汇率和手续费。以及2号货币换1号货币的汇率和手续费、问能否通过一些货币更换的关系使得换回货币1的时候使其增值,如果可能,输出YES,如果不可能输出NO。


思路:因为这样的一些兑换关系,使得一个图是可以互通的,也就是说从1号货币换到了i号货币,那么一定能从i号货币换回1号货币,那么我们就找一条环,使得其价值能够无限增加就可以了,那么我们就把问题转化到最短路求环的问题上了,既然SPFA能够判负环,那么SPFA也就能够判正环。


AC代码:


#include<stdio.h>
#include<string.h>
#include<vector>
#include<queue>
using namespace std;
struct node
{
    int to;
    double rate;
    double shouxu;
}now;
int out[10001];
vector<node>mp[10000];
double dis[10001];
int vis[10001];
int n,m,ss;
double v;
int SPFA()
{
    queue<int >s;
    memset(vis,0,sizeof(vis));
    memset(out,0,sizeof(out));
    memset(dis,0,sizeof(dis));
    dis[ss]=v;
    vis[ss]=1;
    s.push(ss);
    while(!s.empty())
    {
        int u=s.front();
        s.pop();vis[u]=0;
        out[u]++;
        if(out[u]>=n)return 1;
        for(int i=0;i<mp[u].size();i++)
        {
            now=mp[u][i];
            int v=now.to;
            double rate=now.rate;
            double shouxu=now.shouxu;
            if(dis[v]<rate*(dis[u]-shouxu))
            {
                dis[v]=rate*(dis[u]-shouxu);
                if(vis[v]==0)
                {
                    s.push(v);
                    vis[v]=1;
                }
            }
        }
    }
    return 0;
}
int main()
{
    while(~scanf("%d%d%d%lf",&n,&m,&ss,&v))
    {
        for(int i=1;i<=n;i++)mp[i].clear();
        for(int i=0;i<m;i++)
        {
            int x,y;double a,b,c,d;
            scanf("%d%d%lf%lf%lf%lf",&x,&y,&a,&b,&c,&d);
            now.to=y;
            now.rate=a;
            now.shouxu=b;
            mp[x].push_back(now);
            now.to=x;
            now.rate=c;
            now.shouxu=d;
            mp[y].push_back(now);
        }
        if(SPFA())
        {
            printf("YES\n");
        }
        else printf("NO\n");
    }
}








评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值