Poj 3692 Kindergarten【最大团】

Kindergarten

Time Limit: 2000MS

 

Memory Limit: 65536K

Total Submissions: 6246

 

Accepted: 3077

Description

In a kindergarten, there are a lot of kids. All girls of the kids know each other and all boys also know each other. In addition to that, some girls and boys know each other. Now the teachers want to pick some kids to play a game, which need that all players know each other. You are to help to find maximum number of kids the teacher can pick.

Input

The input consists of multiple test cases. Each test case starts with a line containing three integers
GB (1 ≤ GB ≤ 200) and M (0 ≤ M ≤ G × B), which is the number of girls, the number of boys and
the number of pairs of girl and boy who know each other, respectively.
Each of the following M lines contains two integers X and Y (1 ≤ X≤ G,1 ≤ Y ≤ B), which indicates that girl X and boy Y know each other.
The girls are numbered from 1 to G and the boys are numbered from 1 to B.

The last test case is followed by a line containing three zeros.

Output

For each test case, print a line containing the test case number( beginning with 1) followed by a integer which is the maximum number of kids the teacher can pick.

Sample Input

2 3 3

1 1

1 2

2 3

2 3 5

1 1

1 2

2 1

2 2

2 3

0 0 0

Sample Output

Case 1: 3

Case 2: 4

Source

2008 Asia Hefei Regional Contest Online by USTC

 

题目大意:有n个男的,有m个女的,k个关系,其中男的互相认识,其中女的互相认识,给出的k个关系中,表示男a认识女b,现在要玩一个游戏,希望参加游戏的人互相都认识,求最大人数。


思路:求这个最大人数,就是在求最大团,意淫一下,最大团==其补图的最大独立集。那么结果就是n+m-最大匹配数。


AC代码:

#include<stdio.h>
#include<string.h>
#include<vector>
using namespace std;
int map[520][520];
int vis[520];
int match[520];
int n,m,k;
int find(int x)
{
    for(int i=1;i<=m;i++)
    {
        if(map[x][i]==1&&vis[i]==0)
        {
            vis[i]=1;
            if(match[i]==-1||find(match[i]))
            {
                match[i]=x;
                return 1;
            }
        }
    }
    return 0;
}
int main()
{
    int kase=0;
    while(~scanf("%d%d%d",&n,&m,&k))
    {
        if(n+m+k==0)break;
        memset(match,-1,sizeof(match));
        for(int i=1;i<=n;i++)
        {
            for(int j=1;j<=m;j++)
            {
                map[i][j]=1;
            }
        }
        for(int i=0;i<k;i++)
        {
            int x,y;
            scanf("%d%d",&x,&y);
            map[x][y]=0;
        }
        int output=0;
        for(int i=1;i<=n;i++)
        {
            memset(vis,0,sizeof(vis));
            if(find(i))output++;
        }
        printf("Case %d: %d\n",++kase,n+m-output);
    }
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值