POJ 3692 Kindergarten (二分图 最大团)

91 篇文章 1 订阅

Kindergarten
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 5660 Accepted: 2756

Description

In a kindergarten, there are a lot of kids. All girls of the kids know each other and all boys also know each other. In addition to that, some girls and boys know each other. Now the teachers want to pick some kids to play a game, which need that all players know each other. You are to help to find maximum number of kids the teacher can pick.

Input

The input consists of multiple test cases. Each test case starts with a line containing three integers
G, B (1 ≤ G, B ≤ 200) and M (0 ≤ MG × B), which is the number of girls, the number of boys and
the number of pairs of girl and boy who know each other, respectively.
Each of the following M lines contains two integers X and Y (1 ≤ X≤ G,1 ≤ Y ≤ B), which indicates that girl X and boy Y know each other.
The girls are numbered from 1 to G and the boys are numbered from 1 to B.

The last test case is followed by a line containing three zeros.

Output

For each test case, print a line containing the test case number( beginning with 1) followed by a integer which is the maximum number of kids the teacher can pick.

Sample Input

2 3 3
1 1
1 2
2 3
2 3 5
1 1
1 2
2 1
2 2
2 3
0 0 0

Sample Output

Case 1: 3
Case 2: 4

Source

2008 Asia Hefei Regional Contest Online by USTC

题目链接:http://poj.org/problem?id=3692

题目大意:一些男生和女生,男生们相互都认识,女生们相互都认识,给出男女生的认识关系,要求一个最大的集合,集合中任意两个人都互相认识,求这个最大集合的元素个数

题目分析:二分图最大团问题,根据定理:
二分图最大团=原图补图的最大独立集
最大独立集=总点数-最大匹配
用匈牙利算法解出原图补图的最大匹配即可算出最大团中元素个数 (注:一般图的最大团问题是NP问题)

代码:

#include <cstdio>
#include <cstring>
int const MAX = 205;
int cx[MAX], cy[MAX];
bool vis[MAX], map[MAX][MAX];
int g, b, m;

int DFS(int x)
{   
    for(int y = 1; y <= b; y++)
    {
        if(!vis[y] && map[x][y])
        {
            vis[y] = true;
            if(cy[y] == -1 || DFS(cy[y]))
            {
                cy[y] = x;
                cx[x] = y; 
                return 1;
            }
        }
    }
    return 0;
}

int MaxMatch()
{
    int ans = 0;
    memset(cx, -1, sizeof(cx));
    memset(cy, -1, sizeof(cy));
    for(int i = 1; i <= g; i++)
    {
        if(cx[i] == -1)
        {
            memset(vis, false, sizeof(vis));
            ans += DFS(i);
        }
    }
    return ans;
}

int main()
{   
    int ca = 1;
    while(scanf("%d %d %d", &g, &b, &m) != EOF && (g + b + m))
    {
        memset(map, true, sizeof(map));
        for(int i = 0; i < m; i++)
        {
            int u, v;
            scanf("%d %d", &u, &v);
            map[u][v] = false;
        }
        printf("Case %d: %d\n", ca ++, g + b - MaxMatch());
    }
}



  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值