【城会玩】hrbust 1341Who will be punished【思维】

Who will be punished
Time Limit: 1000 MSMemory Limit: 32767 K
Total Submit: 543(91 users)Total Accepted: 204(78 users)Rating: Special Judge: No
Description

This time,suddenly,teacher Li wants to find out who have missed interesting DP lesson to have fun.The students who are found out will get strictly punishment.Because,teacher Li wants all the students master the DP algorithm.

However,Li doesn't want to waste the class time to call over the names of students.So he let the students to write down their names in one paper.To his satisfaction,this time, only one student has not come.

He can get the name who has not come to class,but,it is troublesome,and,teacher always have many things to think about,so,teacher Li wants you, who is in the ACM team, to pick out the name.

Input

There are several test cases.The first line of each case have one positive integer N.N is the  number of the students,and N will not greater than 500,000.

Then,following N lines,each line contains one name of students who have attended class.The N-1 lines are presented after N lines.These N-1 lines indicates the names of students who have come to class this time,one name in one line.

The length of student's name is not greater than 30.

Process to the end of file.

Output
For each test case, first print a line saying "Scenario #k", where k is the number of the test case.Then output the name of the student who have not come to class.One case per line.Print a blank line after each test case, even after the last one.
Sample Input

3

A

B

C

B

C

Sample Output

Scenario #1

A


题目大意:有n个人名,n-1行到场的人名,输出没到场的人名。


思路:

1、暴力,每一次输入一个到场人名,都去人名册中匹配一次,对上了的人,vis【】数组对应标记一下,找到没有vis【】标记的那个人,复杂度O(n^2),明显超时。


2、使用STLmap映射,对应到场人名都映射一个int值,即mp【a【i】】=x;然后每输入一个到场的人名,对应vis【mp【a【i】】】标记一下,找到没有vis【】标记的那个人,复杂度O(n),不会超时,写了一发,提交,MLE,500000*30的char数组,超出32m内存,明显这个题的目的在于让你继续优化,使得无论是空间上还是时间上都优化到最极致。


3、思考无果,参考前辈们的思路:

①首先引入亦或位运算:二进制数中,相同为0,不同为1。

②我们不妨做一下这个亦或运算:2^3^4^3^4值为2,同理,我们在做一下这个亦或运算:4^5^8^10^5^4^10值为8.不难发现,我们可以将这个规律递推到字符串上。

③那么其亦或值,就是我们要得到的结果。


AC代码:


#include<stdio.h>
#include<string.h>
using namespace std;
char a[50];
char tmp[50];
int main()
{
    int n;
    int kase=0;
    while(~scanf("%d",&n))
    {
        for(int i=0;i<2*n-1;i++)
        {
            if(i==0)
            {
                scanf("%s",a);
            }
            else
            {
                scanf("%s",tmp);
                for(int i=0;i<strlen(tmp);i++)
                {
                    a[i]=a[i]^tmp[i];
                }
            }
        }
        printf("Scenario #%d\n",++kase);
        printf("%s\n\n",a);
    }
}




  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值