hrbust 1434 Quick out of the Harbour【Bfs+优先队列】

Quick out of the Harbour
Time Limit: 3000 MSMemory Limit: 65536 K
Total Submit: 10(6 users)Total Accepted: 8(6 users)Rating: Special Judge: No
Description
Captain Clearbeard decided to go to the harbour for a few days so his crew could inspect and repair the ship. Now, a few days later, the pirates are getting landsick(Pirates get landsick when they don't get enough of the ships' rocking motion. That's why pirates often try to simulate that motion by drinking rum.). Before all of the pirates become too sick to row the boat out of the harbour, captain Clearbeard decided to leave the harbour as quickly as possible.
Unfortunately the harbour isn't just a straight path to open sea. To protect the city from evil pirates, the entrance of the harbour is a kind of maze with drawbridges in it. Every bridge takes some time to open, so it could be faster to take a detour. Your task is to help captain Clearbeard and the fastest way out to open sea.
The pirates will row as fast as one minute per grid cell on the map. The ship can move only horizontally or vertically on the map. Making a 90 degree turn does not take any extra time.
Input
The first line of the input contains a single number: the number of test cases to follow. Each test case has the following format:
1. One line with three integers, h, w (3 <= h;w <= 500), and d (0 <= d <= 50), the height and width of the map and the delay for opening a bridge.
2.h lines with w characters: the description of the map. The map is described using the following characters:
—"S", the starting position of the ship.
—".", water.
—"#", land.
—"@", a drawbridge.
Each harbour is completely surrounded with land, with exception of the single entrance.
Output
For every test case in the input, the output should contain one integer on a single line: the travelling time of the fastest route to open sea. There is always a route to open sea. Note that the open sea is not shown on the map, so you need to move outside of the map to reach open sea.
Sample Input
26 5 7######S..##@#.##...##@####.###4 5 3######S#.##@..####@#
Sample Output
1611
Source
BAPC 2011

题目大意:

S表示船的起点,@代表可以打开的吊桥,不过想要打开吊桥需要时间d,问你船想离开这个地图的最小花费时间。


思路:


1、因为有吊桥的出现,我们Bfs优先从时间+最短路径优先,变成了最短路径优先,然而我们显然需要的是时间优先,所以加入一个优先队列元素,使得队头时间最小,按照时间优先的顺序来Bfs即可。


2、注意地图大小,注意边界判定。


Ac代码:

#include<stdio.h>
#include<string.h>
#include<queue>
using namespace std;
struct node
{
    int x,y,time;
    friend bool operator <(node a,node b)
    {
        return a.time>b.time;
    }
}now,nex;
char a[651][651];
int vis[651][651];
int fx[4]={0,0,1,-1};
int fy[4]={1,-1,0,0};
int n,m,k;
void Bfs_priority(int x,int y)
{

    memset(vis,0,sizeof(vis));
    priority_queue<node>s;
    vis[x][y]=1;
    now.x=x;
    now.y=y;
    now.time=0;
    s.push(now);
    while(!s.empty())
    {
        now=s.top();
        if(now.x==0||now.x==n-1||now.y==0||now.y==m-1)
        {
            printf("%d\n",now.time+1);
            return ;
        }
        s.pop();
        for(int i=0;i<4;i++)
        {
            nex.x=now.x+fx[i];
            nex.y=now.y+fy[i];
            if(nex.x>=0&&nex.x<n&&nex.y>=0&&nex.y<m&&a[nex.x][nex.y]!='#'&&vis[nex.x][nex.y]==0)
            {
                if(a[nex.x][nex.y]=='@')
                {
                    nex.time=now.time+k+1;
                }
                else nex.time=now.time+1;
                vis[nex.x][nex.y]=1;
                s.push(nex);
            }
        }
    }
    return ;
}
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        int sx,sy;
        scanf("%d%d%d",&n,&m,&k);
        for(int i=0;i<n;i++)
        {
            scanf("%s",a[i]);
            for(int j=0;j<m;j++)
            {
                if(a[i][j]=='S')
                {
                    sx=i;
                    sy=j;
                }
            }
        }
        Bfs_priority(sx,sy);
    }
}
/*
#####
#...#
#@#.#
#...#
#@###
#S###
*/




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值