Poj 1325 Machine Schedule【二分匹配-------最小点覆盖】

Machine Schedule
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 14439 Accepted: 6156

Description

As we all know, machine scheduling is a very classical problem in computer science and has been studied for a very long history. Scheduling problems differ widely in the nature of the constraints that must be satisfied and the type of schedule desired. Here we consider a 2-machine scheduling problem. 

There are two machines A and B. Machine A has n kinds of working modes, which is called mode_0, mode_1, ..., mode_n-1, likewise machine B has m kinds of working modes, mode_0, mode_1, ... , mode_m-1. At the beginning they are both work at mode_0. 

For k jobs given, each of them can be processed in either one of the two machines in particular mode. For example, job 0 can either be processed in machine A at mode_3 or in machine B at mode_4, job 1 can either be processed in machine A at mode_2 or in machine B at mode_4, and so on. Thus, for job i, the constraint can be represent as a triple (i, x, y), which means it can be processed either in machine A at mode_x, or in machine B at mode_y. 

Obviously, to accomplish all the jobs, we need to change the machine's working mode from time to time, but unfortunately, the machine's working mode can only be changed by restarting it manually. By changing the sequence of the jobs and assigning each job to a suitable machine, please write a program to minimize the times of restarting machines. 

Input

The input file for this program consists of several configurations. The first line of one configuration contains three positive integers: n, m (n, m < 100) and k (k < 1000). The following k lines give the constrains of the k jobs, each line is a triple: i, x, y. 

The input will be terminated by a line containing a single zero. 

Output

The output should be one integer per line, which means the minimal times of restarting machine.

Sample Input

5 5 10
0 1 1
1 1 2
2 1 3
3 1 4
4 2 1
5 2 2
6 2 3
7 2 4
8 3 3
9 4 3
0

Sample Output

3

Source


题目大意:

A机器有n个模式,B机器有m个模式,一共有k个任务,初始的时候A、B机器都是模式0,一个任务可以在机器A的ai模式下完成,也可以在机器B的bi模式下完成,每一次机器想要更换模式都需要重新启动,问完成所有任务最少重新启动多少次?


思路:


1、经典的二分图模型。将A机器的模式看成左集合,将B机器的模式看成右集合,对应一个任务,要么选择ai,要么选择bi来完成,那么ai和bi之间连一条边,表示这两个模式需要二选一,那么求得的最大匹配==最小点覆盖。


2、ans==最小点覆盖。另外注意,如果当输入的某个任务有模式0的时候,我们可以不用考虑它,因为机器初始的模式就是0.


Ac代码:


#include<stdio.h>
#include<string.h>
#include<vector>
using namespace std;
vector<int >mp[10004];
int vis[10004];
int match[10004];
int n,m,k;
int find(int u)
{
    for(int i=0;i<mp[u].size();i++)
    {
        int v=mp[u][i];
        if(vis[v]==0)
        {
            vis[v]=1;
            if(match[v]==-1||find(match[v]))
            {
                match[v]=u;return 1;
            }
        }
    }
    return 0;
}
int main()
{
    while(~scanf("%d",&n))
    {
        if(n==0)break;
        scanf("%d%d",&m,&k);
        memset(match,-1,sizeof(match));
        for(int i=1;i<=n;i++)mp[i].clear();
        for(int i=0;i<k;i++)
        {
            int a,x,y;
            scanf("%d%d%d",&a,&x,&y);
            if(x==0||y==0)continue;
            mp[x].push_back(y);
        }
        int output=0;
        for(int i=1;i<=n;i++)
        {
            memset(vis,0,sizeof(vis));
            if(find(i)==1)
            {
                output++;
            }
        }
        printf("%d\n",output);
    }
}




评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值