Poj 2686 Traveling by Stagecoach【状压dp】

Traveling by Stagecoach
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 3033 Accepted: 1129 Special Judge

Description

Once upon a time, there was a traveler. 

He plans to travel using stagecoaches (horse wagons). His starting point and destination are fixed, but he cannot determine his route. Your job in this problem is to write a program which determines the route for him. 

There are several cities in the country, and a road network connecting them. If there is a road between two cities, one can travel by a stagecoach from one of them to the other. A coach ticket is needed for a coach ride. The number of horses is specified in each of the tickets. Of course, with more horses, the coach runs faster. 

At the starting point, the traveler has a number of coach tickets. By considering these tickets and the information on the road network, you should find the best possible route that takes him to the destination in the shortest time. The usage of coach tickets should be taken into account. 

The following conditions are assumed. 
  • A coach ride takes the traveler from one city to another directly connected by a road. In other words, on each arrival to a city, he must change the coach. 
  • Only one ticket can be used for a coach ride between two cities directly connected by a road. 
  • Each ticket can be used only once. 
  • The time needed for a coach ride is the distance between two cities divided by the number of horses. 
  • The time needed for the coach change should be ignored.

Input

The input consists of multiple datasets, each in the following format. The last dataset is followed by a line containing five zeros (separated by a space). 

n m p a b 
t1 t2 ... tn 
x1 y1 z1 
x2 y2 z2 
... 
xp yp zp 

Every input item in a dataset is a non-negative integer. If a line contains two or more input items, they are separated by a space. 

n is the number of coach tickets. You can assume that the number of tickets is between 1 and 8. m is the number of cities in the network. You can assume that the number of cities is between 2 and 30. p is the number of roads between cities, which may be zero. 

a is the city index of the starting city. b is the city index of the destination city. a is not equal to b. You can assume that all city indices in a dataset (including the above two) are between 1 and m. 

The second line of a dataset gives the details of coach tickets. ti is the number of horses specified in the i-th coach ticket (1<=i<=n). You can assume that the number of horses is between 1 and 10. 

The following p lines give the details of roads between cities. The i-th road connects two cities with city indices xi and yi, and has a distance zi (1<=i<=p). You can assume that the distance is between 1 and 100. 

No two roads connect the same pair of cities. A road never connects a city with itself. Each road can be traveled in both directions.

Output

For each dataset in the input, one line should be output as specified below. An output line should not contain extra characters such as spaces. 

If the traveler can reach the destination, the time needed for the best route (a route with the shortest time) should be printed. The answer should not have an error greater than 0.001. You may output any number of digits after the decimal point, provided that the above accuracy condition is satisfied. 

If the traveler cannot reach the destination, the string "Impossible" should be printed. One cannot reach the destination either when there are no routes leading to the destination, or when the number of tickets is not sufficient. Note that the first letter of "Impossible" is in uppercase, while the other letters are in lowercase. 

Sample Input

3 4 3 1 4
3 1 2
1 2 10
2 3 30
3 4 20
2 4 4 2 1
3 1
2 3 3
1 3 3
4 1 2
4 2 5
2 4 3 4 1
5 5
1 2 10
2 3 10
3 4 10
1 2 0 1 2
1
8 5 10 1 5
2 7 1 8 4 5 6 3
1 2 5
2 3 4
3 4 7
4 5 3
1 3 25
2 4 23
3 5 22
1 4 45
2 5 51
1 5 99
0 0 0 0 0

Sample Output

30.000
3.667
Impossible
Impossible
2.856

Hint

Since the number of digits after the decimal point is not specified, the above result is not the only solution. For example, the following result is also acceptable. 
30.0
3.66667
Impossible
Impossible
2.85595

Source


题目大意:

一共有N张马车票,其中一共有m个城市,p条无向边,起点在点a处,终点在点b处,对应p条无向边,每条边三个元素,表示在x,y两点之间有一条长度为z的路。其中过一条路就需要使用一张马车票,对应走完这条路的花费的时间为:z/马车票的值,输出这个最小花费,从起点a到达终点b。


思路:


1、首先我们观察到数据范围,其中马车票最多有8张,那么我们对应可以考虑使得这部分进行状态压缩,因为马车票一共有八张,那么一个长度为8的一个二进制数就可以表示当前使用马车票的情况。比如一个数值5:00000101,表示使用了第一张马车票和第三张马车票,其余的马车票没有使用过。


2、那么设定数组:dp【i】【j】,表示现在走到了城市j,使用的马车票的情况为i的情况下的最小花费。

那么不难理解其状态转移方程:

dp【i】【v】=dp【q】【u】+w(u,v)/a【j】。(其中q=i-(1<<j)&&城市u和城市v之间有一条边。a【j】表示第j个马车票的值)。

表示马车票使用情况为q的条件下,我们在城市u,使用了第j个马车票之后,走到了城市v,对应使用马车票的情况为i的最小花费的状态转移过程。


3、那么我们一层for枚举状态i,一层for枚举当前要选择使用的车票j,如果状态i中已经使用了车票j,根据二进制位运算的与运算我们可以知道,如果i&(1<<j)!=0,那么说明状态i中包含了第j个车票(使用完了第j个车票)。那么我们此时就可以得到状态q=i-(1<<j)。此时我们再用一层for枚举没有使用第j个车票时候的点作为一个起点,再用一层for枚举使用了第j个车票之后的点作为一个终点,那么其间如果有路,那么就可以进行状态转移了。

①对于与运算:对应位子,同1为1,其余为0

5:00000101,显然现在使用完了第一张和第三张车票,那么如果我们5&(1<<1):

00000101

00000001

--------------&

00000001

显然值不为0,那么表示5这个状态中,已经使用了第一张车票。

同理,如果我们5&(1<<2):

00000101

00000010

--------------&

00000000

显然值为0,那么表示5这个状态中,没有使用第一张车票.

那么对于与运算,我们就能判定当前状态i,是否已经使用了第j个车票了。


4、思路构建完毕,剩下的就是实现代码了,上述过程中状态转移时间复杂度:O(2^n*n*m^2), 其值如果都取最大:2^8*8*30*30≈10^6,显然不会超时。

注意Poj,G++输出的double要用%f,C++输出的double要用%lf。注意一下即可。


Ac代码:


#include<stdio.h>
#include<string.h>
#include<iostream>
#include<algorithm>
using namespace std;
int a[15];
int map[55][55];
double dp[(1<<10)][55];
void init()
{
    memset(map,-1,sizeof(map));
    for(int i=0;i<(1<<10);i++)
    {
        for(int j=0;j<45;j++)
        {
            dp[i][j]=0x3f3f3f3f*1.0;
        }
    }
}
int main()
{
    int n,m,p,aa,bb;
    while(~scanf("%d%d%d%d%d",&n,&m,&p,&aa,&bb))
    {
        if(n==0&&m==0&&p==0&&aa==0&&bb==0)break;
        init();
        for(int i=0;i<n;i++)
        {
            scanf("%d",&a[i]);
        }
        for(int i=0;i<p;i++)
        {
            int x,y,w;
            scanf("%d%d%d",&x,&y,&w);
            map[x][y]=w;
            map[y][x]=w;
        }
        dp[0][aa]=0;
        int end=(1<<n);
        for(int i=0;i<end;i++)
        {
            for(int j=0;j<n;j++)
            {
                if((i&(1<<j))!=0)
                {
                    int q=i-(1<<j);
                    for(int u=1;u<=m;u++)
                    {
                        for(int v=1;v<=m;v++)
                        {
                            if(map[u][v]>-1)
                            {
                                double tmp=map[u][v]*1.0/a[j]*1.0;
                                dp[i][v]=min(dp[i][v],dp[q][u]+tmp);
                            }
                        }
                    }
                }
            }
        }
        double ans=0x3f3f3f3f*1.0;
        for(int i=0;i<end;i++)
        {
            ans=min(ans,dp[i][bb]);
        }
        if(ans==0x3f3f3f3f*1.0)printf("Impossible\n");
        else
        printf("%f\n",ans);
    }
}





评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值