Hrbust 1750 Eternal Victory【贪心+Dfs】

186 篇文章 0 订阅

Eternal Victory
Time Limit: 1000 MSMemory Limit: 65536 K
Total Submit: 18(7 users)Total Accepted: 8(5 users)Rating: Special Judge: No
Description

Valerian was captured by Shapur. The victory was such a great one that Shapur decided to carve a scene of Valerian's defeat on a mountain. So he had to find the best place to make his victory eternal!

He decided to visit all n cities ofPersiato find the best available mountain, but after the recent war he was too tired and didn't want to traverse a lot. So he wanted to visit each of these n cities at least once with smallest possible traverse. Persian cities are connected with bidirectional roads. You can go from any city to any other one using these roads and there is a unique path between each two cities.

All cities are numbered 1 to n. Shapur is currently in the city 1 and he wants to visit all other cities with minimum possible traverse. He can finish his travels in any city.

Help Shapur find how much He should travel.

Input

There are multiple test case, process to the end of file.

First line contains a single natural number n (1 <= n <= 100,000) — the amount of cities.

Next n - 1 lines contain 3 integer numbers each xi, yi and wi (1 <= xi, yi <= n, 0 <= wi <= 2*10,000). xi and yi are two ends of a road and wi is the length of that road.

Output

For each case, output one line, contains a single integer number, the minimal length of Shapur's travel.

Sample Input
3
1 2 3
2 3 4
3
1 2 3
1 3 3
Sample Output
7
9

题目大意:

主人公处于位子1,现在要走到其他各点至少一次,不必要回到原点,问最小花费。


思路:


1、不必要回到原点,我们不妨先将问题转化到需要回到原点上来,那么ans=走到其他各点至少一次并且回到原点的最小花费-从1出发的最长的一条链的花费(不能回头的那种);


2、那么设定sum【i】表示走完第i个点的所有子节点并且回到点i的最小花费。

那么有:sum【i】=2*w+sum【v】;


3、过程维护一条最长链,那么ans=sum【1】-maxn;


Ac代码:

#include<stdio.h>
#include<string.h>
#include<iostream>
using namespace std;
struct node
{
    int from;
    int to;
    int next;
    int w;
}e[5005000];
int head[100500];
int sum[100500];
int cont,maxn;
void add(int from,int to,int w)
{
    e[cont].to=to;
    e[cont].w=w;
    e[cont].next=head[from];
    head[from]=cont++;
}
void Dfs(int u,int from,int pathsum)
{
    maxn=max(maxn,pathsum);
    for(int i=head[u];i!=-1;i=e[i].next)
    {
        int v=e[i].to;
        int w=e[i].w;
        if(v==from)continue;
        Dfs(v,u,pathsum+w);
        sum[u]+=sum[v]+2*w;
    }
}
int main()
{
    int n;
    while(~scanf("%d",&n))
    {
        cont=0;
        maxn=0;
        memset(sum,0,sizeof(sum));
        memset(head,-1,sizeof(head));
        for(int i=0;i<n-1;i++)
        {
            int x,y,w;
            scanf("%d%d%d",&x,&y,&w);
            add(x,y,w);
            add(y,x,w);
        }
        Dfs(1,-1,0);
        printf("%d\n",sum[1]-maxn);
    }
}






  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值