Hdu 4217 Data Structure?【二分+树状数组】

142 篇文章 0 订阅
28 篇文章 1 订阅

Data Structure?

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 3359    Accepted Submission(s): 1077


Problem Description
Data structure is one of the basic skills for Computer Science students, which is a particular way of storing and organizing data in a computer so that it can be used efficiently. Today let me introduce a data-structure-like problem for you.
Original, there are N numbers, namely 1, 2, 3...N. Each round, iSea find out the Ki-th smallest number and take it away, your task is reporting him the total sum of the numbers he has taken away.
 

Input
The first line contains a single integer T, indicating the number of test cases.
Each test case includes two integers N, K, K indicates the round numbers. Then a line with K numbers following, indicating in i (1-based) round, iSea take away the Ki-th smallest away.

Technical Specification
1. 1 <= T <= 128
2. 1 <= K <= N <= 262 144
3. 1 <= Ki <= N - i + 1
 

Output
For each test case, output the case number first, then the sum.
 

Sample Input
  
  
2 3 2 1 1 10 3 3 9 1
 

Sample Output
  
  
Case 1: 3 Case 2: 14
 

Author
iSea@WHU
 

Source

题目大意:


给你N个数,从1~N,每次从中拿第ki小的数,然后去掉这个数,一共拿K次,问累加的和是多少。


思路:


一开始我们让数组都设定为1,表示各个数都没有被拿过,然后我们每一次拿的时候,二分一下树上剩余的第k个数的位子就行了。

过程维护一下即可。


Ac代码:

#include<stdio.h>
#include<string.h>
using namespace std;
int tree[400005];
int n,k;
int lowbit(int x)
{
    return x&(-x);
}
int sum(int x)
{
    int sum=0;
    while(x>0)
    {
        sum+=tree[x];
        x-=lowbit(x);
    }
    return sum;
}
void add(int x,int c)
{
    while(x<=n)
    {
        tree[x]+=c;
        x+=lowbit(x);
    }
}
int main()
{
    int t;
    int kase=0;
    scanf("%d",&t);
    while(t--)
    {
        memset(tree,0,sizeof(tree));
        scanf("%d%d",&n,&k);
        for(int i=1;i<=n;i++)add(i,1);
        long long int output=0;
        for(int i=0;i<k;i++)
        {
            int x;scanf("%d",&x);
            int l=1;
            int r=n;
            int pos=-1;
            while(r-l>=0)
            {
                int mid=(l+r)/2;
                if(sum(mid)>=x)
                {
                    if(sum(mid)==x)pos=mid;
                    r=mid-1;
                }
                else l=mid+1;
            }
            if(pos==-1)continue;
            else output+=pos,add(pos,-1);
        }
        printf("Case %d: %lld\n",++kase,output);
    }
}










  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值