Hdu 6152 Friend-Graph【暴力】

Friend-Graph

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 913    Accepted Submission(s): 479


Problem Description
It is well known that small groups are not conducive of the development of a team. Therefore, there shouldn’t be any small groups in a good team.
In a team with n members,if there are three or more members are not friends with each other or there are three or more members who are friends with each other. The team meeting the above conditions can be called a bad team.Otherwise,the team is a good team.
A company is going to make an assessment of each team in this company. We have known the team with n members and all the friend relationship among these n individuals. Please judge whether it is a good team.
 

Input
The first line of the input gives the number of test cases T; T test cases follow.(T<=15)
The first line od each case should contain one integers n, representing the number of people of the team.( n3000 )

Then there are n-1 rows. The  i th row should contain n-i numbers, in which number  aij  represents the relationship between member i and member j+i. 0 means these two individuals are not friends. 1 means these two individuals are friends.
 

Output
Please output ”Great Team!” if this team is a good team, otherwise please output “Bad Team!”.
 

Sample Input
  
  
1 4 1 1 0 0 0 1
 

Sample Output
  
  
Great Team!

题目大意:


给出N个点,和两点间是否存在边的信息,如果一个团队有三个人或者更多人的小团体互相认识,或者有三个人或者更多人的小团体互相不认识,那么整个队伍就是坏队伍,否则就是好队伍。

我们的任务是判断其是否是一个好团队。


思路:


任务就是在找是否存在三元环和孤立点个数是否大于3.


那么暴力模拟一下就行。我们知道边数多如果不构成三元环的话的情况只能是一个大的环,所以我们暴力去处理就是O(n^2)的。


Ac代码:

#include<stdio.h>
#include<string.h>
using namespace std;
struct node
{
    int x,y;
}e[4500000+50];
int degree[3500];
bool a[3050][3050];
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        int cnt=0;
        int n;
        scanf("%d",&n);
        memset(a,false,sizeof(a));
        memset(degree,0,sizeof(degree));
        for(int i=1;i<=n;i++)
        {
            for(int j=i+1;j<=n;j++)
            {
                int x;
                scanf("%d",&x);
                if(x==1)
                {
                    e[cnt].x=i;
                    e[cnt].y=j;
                    cnt++;
                    a[i][j]=true;
                    a[j][i]=true;
                    degree[i]++;
                    degree[j]++;
                }
            }
        }
        int flag=0;
        int contt=0;
        for(int i=1;i<=n;i++)
        {
            if(degree[i]==0)contt++;
        }
        if(contt>=3)flag=1;
        for(int i=0;i<cnt;i++)
        {
            if(flag==1)break;
            int u=e[i].x;
            int v=e[i].y;
            for(int j=1;j<=n;j++)
            {
                if(j==u||j==v)continue;
                if(a[j][u]==true&&a[j][v]==true)
                {
                    flag=1;
                    break;
                }
            }
            if(flag==1)break;
        }
        if(flag==0)printf("Great Team!\n");
        else printf("Bad Team!\n");
    }
}










  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值