A + B Again
Time Limit: 1000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 34138 Accepted Submission(s): 13848
Problem Description
There must be many A + B problems in our HDOJ , now a new one is coming.
Give you two hexadecimal integers , your task is to calculate the sum of them,and print it in hexadecimal too.
Easy ? AC it !
Input
The input contains several test cases, please process to the end of the file.
Each case consists of two hexadecimal integers A and B in a line seperated by a blank.
The length of A and B is less than 15.
Output
For each test case,print the sum of A and B in hexadecimal in one line.
Sample Input
+A -A+1A 121A -9-1A -121A -AA
Sample Output
02C11-2C-90
#include <stdio.h>
int main()
{
long long a,b,sum;
while(scanf("%llx %llx",&a,&b) != EOF)
{
sum=a+b;
if(sum>=0)
printf("%llX\n",sum); //X要大写
else
printf("-%llX\n",-sum);
}
return 0;
}