LightOJ 1214 Large Division(大数取模)

Given two integers, a and b, you should check whether a is divisible by b or not. We know that an integer a is divisible by an integer b if and only if there exists an integer c such that a = b * c.

Input

Input starts with an integer T (≤ 525), denoting the number of test cases.

Each case starts with a line containing two integers a (-10200 ≤ a ≤ 10200) and b (|b| > 0, b fits into a 32 bit signed integer). Numbers will not contain leading zeroes.

Output

For each case, print the case number first. Then print 'divisible' if a is divisible by b. Otherwise print 'not divisible'.

Sample Input

6

101 101

0 67

-101 101

7678123668327637674887634 101

11010000000000000000 256

-202202202202000202202202 -101

Sample Output

Case 1: divisible

Case 2: divisible

Case 3: divisible

Case 4: not divisible

Case 5: divisible

Case 6: divisible

/*
这是一个大数取模裸题,模板很好背,稍微说一下原理,它用到了同余定理
123%m
* ==((12%m*10%m)%m+3%m)%m
* ==(((10%m+2%m)%m*10%m)%m+3%m)%m
* ==((((1%m*10%m)%m+2%m)%m*10%m)%m+3%m)%m
模板刚好是把这个过程逆着走了一遍,可以自己试试 
*/
#include <iostream>
#include <cstdio>
#include <cstring>
#include <cmath>
using namespace std;
char a[205];
int main()
{
	long long c=1,len,i,j,k,sum,n,ans;
	int t;
	cin>>t;
	while(t--)
	{
		ans=0;
		scanf("%s %lld",a,&n);
		if(a[0]=='-')
		i=1;
		else
		i=0;
		n=abs(n);
		len=strlen(a);
		for(;i<len;i++)
		{
			ans=(10*ans+a[i]-'0')%n;
		}
		if(ans==0)
		cout<<"Case "<<c++<<": divisible"<<endl;
		else
		
		cout<<"Case "<<c++<<": not divisible"<<endl;
	}
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值